Too many access points for Bookmarks

VERIFIED FIXED in M18

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: johng, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3+])

(Reporter)

Description

18 years ago
Currently, you can get your bookmarks 3 big ways (not counting context menus or 
other more hidden access points):

1) Menu at top of Navigator (like Mac 4.x)
2) Button on Toolbar (like Win 4.x)
3) Optional tab in My Sidebar

Since the tab is optional, I'm not too worried about that.  But, as the tangent 
goes in bug 35345, we should *simplify the UI* to have one major access point to 
Bookmarks, not 2.

German, what do you suggest - do we demote the menu heading at the top (and move 
it to be a sub-menu of the Task menu like in 4.x) or completely delete the 
Bookmarks button on the toolbar?  

I suggest we demote the Bookmarks menu and make it a "sub-menu" under Tasks 
while relying on the button on the toolbar as the major access point because:

- this is what most current 4.x users expect
- this is a better place for dragging and dropping the proxy icon from the url 
bar into bookmarks (especially for the Mac when the menu is alwyas at the very 
top of the screen - perhaps a long way from the window)
- fits more cleanly into the scheme of our UI, where the Bookmarks/Personal 
Toolbar contains the links the user customizes.
(Reporter)

Comment 1

18 years ago
Marking M17, but hope that UI can lead to a decision by M16 or soon afterward.
Target Milestone: --- → M17

Comment 2

18 years ago
As a Mac user, even though I'd be very sad to see the toplevel menu go. I completely agree with john. Just remember such a 
change is HIGHLY dependent on the bug to get the 'Add Current page' and 'Manage Bookmarks' commands into that popup 
menu.

Comment 3

18 years ago
this issue was also discusses in bug 36203.  bug 36203 was marked as wontfix 
for the unconvincing reason that some users like the menubar and some like the 
personal toolbar.

my vote goes for the toplevel menu because
- i might not want to use the personal toolbar at all
- toplevel menu automatically gets the alt-B and alt,B keyboard shortcuts
- easier to click with the mouse because it's bigger
- easier to click on because it's (very close to)/(at) the top of the screen

if the decision is to use the personal toolbar instead, is there any chance of 
the bookmarks menu in the personal toolbar menu inheriting the alt-B and alt,B 
keyboard shortcuts?

Comment 4

18 years ago
Yes actually there is another access point that is planned under the tasks menu 
which will then guarantee keyboard access capabilities using modifier+B.
Status: NEW → ASSIGNED
(Reporter)

Comment 5

18 years ago
Added keyword "nsbeta3" since we must do this UI tweak before we ship.

While we will not have concensus on this issue, we must make a choice with 
typical users in mind.
Keywords: nsbeta3
(Reporter)

Comment 6

18 years ago
nsbeta2

UI asked me to nominate this for beta2 because we want usability feedback on 
what happens if we remove Bookmarks from the menu (which is an additional and 
unnecessary access point).  It also is a low risk change.
Keywords: nsbeta2

Comment 7

18 years ago
John, we're getting a lot of push back from the engineers about this,
particularly Ben.  What we talked about recently is temporarily disabling the
menu in the mozilla build just to see what kind of flame-fest we create.
(Reporter)

Comment 8

18 years ago
The controversy is precisely why we should do this in nsbeta2 - so we can get 
user feedback.  The mozilla test is fine, but they are not the target customer 
(beta2 users are a slightly better sample set).

So my answer is go ahead and do the mozilla test, but we have until June 22 to 
get this in beta2, so let's go ahead and put it into beta2 (aka remove the menu 
item for beta2).  For beta3, we may decide to bring back the Bookmarks menu item 
(wouldn't surprise me at all), but we should try to push the envelope on 
reducing clutter in the UI.
(Reporter)

Comment 9

18 years ago
assigning to Don to push for a nsbeta2 decision.
Assignee: german → don
Status: ASSIGNED → NEW

Comment 10

18 years ago
Putting on [nsbeta2-] radar. We would not hold beta 2 for this.  It needs more 
discussion, and we can decide and do during UI freeze later.
Whiteboard: [nsbeta2-]

Comment 11

18 years ago
Personally, I would be much happier to see Bookmarks left in the menu, and
removed from the Personal Toolbar. That would allow me to close the personal
toolbar, and still access bookmarks. I actually like having them in the menu
instead.

Comment 12

18 years ago
I second that.  I always prefered Netscape 3.x to Netscape 4.x in this regard.

Comment 13

18 years ago
agree that the button needs to be removed from the personal toolbar.  The 
personal toolbar should be just that -- personal.  I'm away from mozilla, so I 
can't check, but is there a way to remove the bookmarks button from that 
toolbar?  If not, that's all the more reason to leave the listing in a top 
level menu.  Otherwise, users who hide their personal toolbar (the first thing 
I do) will have no desirable way to quickly go to a bookmark.  Also ensures 
compatibility with IE (not that this was ever reason to do anything before).  
Although, the idea of a bookmarks listing in a top level menu seems a little 
awkward to me, wrt UI.  cc matthew for comment...

Comment 14

18 years ago
* Bookmarks are to the Web what toolbars are to other apps -- access to
  frequently-used features. As such, they *demand* a prominent interface -- not
  one which will be hidden in a submenu, or in a toolbar which many users have
  turned off.

* If you took away the Bookmarks top-level menu, you would slow down my bookmark
  access by approximately a factor of three. (It wouldn't be such a major effect
  on non-Mac systems, where the menus aren't at the top of the screen so aren't
  so quick to get at, and where main menus -- like other menus -- are handled by
  XPToolkit with all its menu foibles.)

* Confusion caused by a Personal Toolbar which contains a Bookmarks button is
  true, but a red herring -- I think having a special bookmarks folder for the
  Personal Toolbar is probably more trouble than it's worth, and making it either
  completely distinct (as in IE's `Links' toolbar), or making it a Bookmarks
  Toolbar (for showing as many of the first bookmarks as would fit), would result
  in greater understanding (and encourage more efficient bookmark arrangement) on
  the part of users overall.

* The only advantage the Bookmarks button in 4.x had over the main menu was that
  (except on Unix versions after 4.04) you could drag a proxy icon to exactly
  where you wanted in the bookmarks list -- you can't do that XP with the main
  menus because of the Mac menu bar. But we have the Bookarks sidebar panel for
  that now, so that's no longer an issue.

I recommend:
* retain the Bookmarks main menu
* remove the Bookmarks menu from the Personal Toolbar
* investigate ways to resolve the confusion between the Personal Toolbar and the
  Bookmarks as a whole -- either by making them exactly the same thing (as in
  iCab), or completely distinct things (as in IE).

Comment 15

18 years ago
mpt has it right.  slamm for m18.
Assignee: don → slamm
Target Milestone: M17 → M18

Comment 16

18 years ago
*** Bug 44964 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
Nav triage team: [nsbeta3+]
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
(Assignee)

Comment 18

18 years ago
I removed the bookmarks folder from the personal toolbar.
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
if location field is shortest there will be more place for button for bookmarks 
like in NS4.xx so then this peronal toolbar which everyone hates becouse it look 
like "Links" field in Explorer

Comment 20

18 years ago
can be removed

Comment 21

18 years ago
I am still seeing the Bookmarks folder in the personal toolbar for Linux build
2000080505.

Comment 22

18 years ago
VERIFIED Fixed with the 2000082108 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.