All users were logged out of Bugzilla on October 13th, 2018

mysql has too many open connections, bugzilla dies completely

RESOLVED DUPLICATE of bug 441592

Status

RESOLVED DUPLICATE of bug 441592
10 years ago
10 years ago

People

(Reporter: wil.deny, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: bugzilla 3.0.4/testopia 2.0-RC2

Did a fresh installation of Bugzilla and Testopia.  It works great, until mysql crashes.  Restarting mysql "fixes" it, but the problem returns.  my mysql-HUPing cronjob has eliminated the symptoms, but not the cause.

I'm running mod_perl (required for xmlrpc) which seems to be where the dragons lie.  Sorry I can't give better steps to reproduce it, but more like a timebomb than a landmine.

Reproducible: Always

Steps to Reproduce:
1. turn on mod_perl in your httpd conf.
2. use testopia to run some tests
3. eventually, it will die with a "too many open connections" message.



running on FC6: 2.6.18-1.2798.fc6
(Assignee)

Comment 1

10 years ago
Guessing this is caused by leaked connections from somewhere in Testopia.
(Assignee)

Comment 2

10 years ago
Max, 

Any insight into what I should be looking for here?
Testopia only ever uses Bugzilla->dbh for connections.

Comment 3

10 years ago
Fixed in 3.0.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441592
You need to log in before you can comment on or make changes to this bug.