playbackrate=1 added to <video> and <audio> in the DOM regardless of HTML source

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Build id:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080811020618 Minefield/3.1a2pre

Steps to reproduce:
 1) Load http://software.hixie.ch/utilities/js/live-dom-viewer/?%3C!DOCTYPE%20html%3E%0A%3Cvideo%3E%3C%2Fvideo%3E%0A%3Cvideo%20playbackrate%3D2%3E%3C%2Fvideo%3E%0A%3Caudio%3E%3C%2Faudio%3E%0A%3Caudio%20playbackrate%3D2%3E%3C%2Faudio%3E

Actual results:
All video and audio elements have a playbackrate=1 attribute.

Expected results:
Expected no playbackrate=1 attribute in the DOM when no corresponding source and expected playbackrate=2 when source says so.
This bug no longer occurs, because mozilla-central changeset 250cef7cf0d6 (bug 462953) removed playbackRate from the IDL as the underlying functionality was not implemented.

I guess there's a good chance the bug will come back when we get around to implementing playbackRate for real.  I've made a note of this bug in the bug for implementing playbackRate (bug 495040).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 2

10 years ago
Technically it was implemented in that the GStreamer backend had working playback rate. The Ogg backend didn't however.
True, sorry about that.  The prototype QuickTime backend supported it too.
You need to log in before you can comment on or make changes to this bug.