Closed Bug 450941 Opened 12 years ago Closed 12 years ago

"Cannot connect" message window floods when thunderbird checks for mail but mail server unreachable

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: joris, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080708)

Under certain configurations, Thunderbird will provide an extreme flood of "cannot connect to mail server" messages when it is checking for e-mail (either automatically or manually triggered).
For details about "certain configurations", see "Steps to reproduce".

Reproducible: Always

Steps to Reproduce:
1. Setup IMAP account.
2. Ensure lots of mail folders are on your IMAP server.
3. Check "Check this folder for new messages" under a lot of folders.
4. Ensure your mail server is unreachable (anyway you like).
5. Wait for Thunderbird to check for mail or press "Get mail".
6. Get a lot of "cannot connect to server" messages popping up.
Actual Results:  
Get a lot of "cannot connect to server" messages popping up.

Expected Results:  
Several options, but you SHOULD warn me only once as a requirement:
*) A better dialog box allows me to select "work offline", "retry", "ignore". If I select ignore, do so for everything(?).
*) ...

Extensions:
*) Automatic online/offline would be valued by me (such as Outlook in Microsoft Exchange Server mode). Does need very clear indications in status bar (these would be valued anyways).
*) Per account online/offline (not confirmed and probably undesirable).

I can only confirm this for Windows version of Thunderbird. The problem might extend to other versions as well.
The problem is mostly a user annoyance and makes the software a lot less friendly to use.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
Cannot connect to server mail.comcast.net and always time out.  Have Windows XP with Comcast McAfee.  Re-installed Thunderbird and restored PC to working date to no avail.  PLEASE HELP!!
You need to log in before you can comment on or make changes to this bug.