Calendar view will not refresh after accepting event invitation from Outlook

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: sga, Unassigned)

Tracking

Lightning 0.9
x86
Linux
Dependency tree / graph

Details

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: lightning 0.9pre build 2008081718

After i accept an event invitation from Outlook the accepted event will not show up in the calendar, but it is stored on the CalDAV Server (DAViCal 0.9.5.1) correctly (seen via Web Interface). When adding another event via "New Event" button it is also stored on the server, but will not show up until tbird is restarted.

The Error Console shows this:
Error: aDOMWindow.arguments[0].QueryInterface is not a function
Source File: file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 850

Error: syntax error
Source File: file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendarModule.js -> file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calDavCalendar.js
Line: 1009

Error: syntax error
Source File: file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendarModule.js -> file:///home/sga/.mozilla-thunderbird/pi8wtb4u.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calDavCalendar.js
Line: 866


I have to restart Thunderbird to get lightning working again.

When accepting the invitation and storing the event to a local calendar everything runs fine.

When i copy the event from the message source and save/import als local .ics file everything is fine, too.

Reproducible: Always

Steps to Reproduce:
1. Receive Event Invitation from Outlook via eMail
2. Accept the invitation -> store to CalDAV (DAViCal 0.9.5.1) calendar

Actual Results:  
The accepted event is stored on the CalDAV Server, but is not shown in lightning.

Expected Results:  
The accepted event should be displayed.
Reporter

Comment 1

11 years ago
If anybody needs an outlook invitation for testing just let me know.
I suggest to enable the advanced preference "calendar.debug.log" as described on
<https://wiki.mozilla.org/Calendar:GDATA_Provider#Enabling_calendar.debug.log> to get the CalDAV provider output in the Error Console. (Maybe do the same for the advanced preference "calendar.debug.log.verbose".)

The output might give some clues what the "syntax error" refers to.
Component: Import and Export → Provider: CalDAV
QA Contact: import-export → caldav-provider
Reporter

Comment 3

11 years ago
I just completed logging the stuff on another Thunderbird installation (this time on windows, same build). See attachment.
Reporter

Comment 4

11 years ago
Posted file Advanced debug.log (obsolete) —
Reporter

Updated

11 years ago
Attachment #334452 - Attachment mime type: application/octet-stream → text/utf8
Attachment #334452 - Attachment mime type: text/utf8 → text/plain
Attachment #334255 - Attachment mime type: text/calendar → text/plain
Sebastian, what version did you use for attaching the log? Looking at the release 0.9 source, I can't relate the syntax errors mentioned in the log to the code.
Reporter

Comment 6

11 years ago
That was 0.9pre build 2008081718 as mentioned when opening this bug last month.

I'll check what output is produced with 0.9 release version and add that output shortly.
Reporter

Comment 7

11 years ago
Posted file Advanced debug.log
Log Output from lightning 0.9 release Version
Attachment #334452 - Attachment is obsolete: true

Comment 8

10 years ago
Hi,

I think this bug is related to what I found here:

https://bugzilla.mozilla.org/show_bug.cgi?id=476312

I think it may be appropriate to list this bug as a dependency, or else create a new one that encompasses the entire class of these bugs.

I have not looked at the source, so I could be wrong, but I think there is more than meets the eye.
(In reply to comment #8)
This bug is about unconfirmed caldav provider refresh / view display issues. I see no relation to the Today Pane or bug 476312.

Comment 10

10 years ago
This bug seems related/identical to:

 https://bugzilla.mozilla.org/show_bug.cgi?id=477248

It's confirmed for lightning0.9 and lightning1.0pre (latest check is nightly 20090303).
Jeroen, are you able to reproduce the issue after the checkin for Bug 477248?

Sebastian, could you retest using Thunderbird 3 Beta 2 or newer with Lightning 1.0pre?

Comment 12

10 years ago
Stefan,

Since Bug 477248 is solved I don't have any problems anymore accepting outlook invitations. Adding new events after this also show up correctly in the caldav calendar in lightning. 
I think the issue addressed here is a sub-part of what Bug 477248 is about.

So according to me, this is solved...
Reporter

Comment 13

10 years ago
Hi,

it's working for me too. Great work, thanks!
Resolving as worksforme based on previous comments, adding dependency to bug 477248.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Depends on: 477248
Resolution: --- → WORKSFORME
Target Milestone: --- → 1.0
Version: unspecified → Lightning 0.9
Target Milestone: 1.0 → ---
You need to log in before you can comment on or make changes to this bug.