Information displayed in the today pane may become out of sync with current task/event information. This decoupling may lead unexpected behaviour including update or refresh errors when adding or modifying tasks or events in today pane.

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: bonjo90, Unassigned)

Tracking

Lightning 0.9
x86
Linux

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008123110 GranParadiso/3.0.5
Build Identifier: Lightning 0.9 (2008092321)

Marking tasks completed in the today pane does not necessarily update the pane. Later updating progress may lead to, "An error occurred when writing to the calendar" with error number: Error Number: MODIFICATION_FAILED

Reproducible: Always

Steps to Reproduce:
Using Thunderbird version 2.0.0.18 (20081206), and Lightning 0.9 (2008092321).

This assumes you have an active calender (I happen to use two), populated with some events and tasks.

1. Open today pane (F11) in Thunderbird.

2. Set the today pane to show "Events and Tasks"

3. "Show completed Tasks" should be unchecked.

4. Right click on a task, and select, "Mark completed".

5. Right click the same task, and try to modify the progress (set the progress to 75%)
Actual Results:  
1. After marking the task completed, the task continues to show, as if it is still pending.

2. If you try to change something, you get an error: 
An error occurred when writing to the calendar School!
Error Number: MODIFICATION_FAILED

*The task 

Expected Results:  
That the today pane refreshes itself and does not display the task.

More fundamentally, that any modification work with the updated task properties, and not try to change the displayed task properties.
Component: General → Tasks
QA Contact: general → tasks
Summary: version 2.0.0.18 (20081206) → Marking tasks completed in the today pane does not necessarily update the pane
Version: unspecified → Lightning 0.9
Works for me using Lightning 1.0pre (2009020204) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090202 Shredder/3.0b2pre. After marking the task as completed it is immediately removed from the task list.
(Reporter)

Comment 2

10 years ago
I tried to reproduce this, and can confirm that something is wrong with the logic implementation: I am reasonably certain that this bug arises when the information displayed in the today pane (which is what I manipulate) becomes uncoupled with the actual information contained by the today pane.

More specifically, although I have not looked at the source, it seems like the information displayed by the today pane is not being properly refreshed after certain modifications, or in certain conditions. I suspect that if you were to examine the modification code, you would find that some operations modify the displayed information without refreshing the display.

I believe this failure to refresh the displayed information after the modification of a task or event is modified is not only the root cause of this bug, but also manifests itself in the following bugs:

https://bugzilla.mozilla.org/show_bug.cgi?id=424328
https://bugzilla.mozilla.org/show_bug.cgi?id=466979
https://bugzilla.mozilla.org/show_bug.cgi?id=451027

FIX:

   I believe these bugs may be fixed by modifying the function used to edit task and event objects to automatically refresh the display after;

   a) modifying any property of an existing object, or
   b) upon completion of the insertion of a new (task/event) object, or
   c) upon completion of the deletion of a new (task/event) object

Implementing a call to refresh the today pane at such a low level, should prevent the displayed information from decoupling with the actual information.
Severity: normal → major
Keywords: mail-integration
Summary: Marking tasks completed in the today pane does not necessarily update the pane → Information displayed in the today pane may become out of sync with current task/event information. This decoupling may lead unexpected behaviour including update or refresh errors when marking tasks completed in today pane.
(Reporter)

Comment 3

10 years ago
I have upgraded the status of this bug to reflect my belief that this is a fundamental flaw in how the today pane updates and may lead to very subtle errors unless corrected.

I request that someone please review my previous comment, and specifically look at both the plausibility of my theory, and whether this defect would be the cause of the above mentioned bugs.

If so, I think it may be useful to list those defects as related to this one.
What build did you use for retest? 0.9? Please retest in a new test profilesing either Sunbird 1.0pre or Lightning 1.0pre + Thunderbird 3.0b2pre because the issue seems to be fixed already.
(Reporter)

Updated

10 years ago
Summary: Information displayed in the today pane may become out of sync with current task/event information. This decoupling may lead unexpected behaviour including update or refresh errors when marking tasks completed in today pane. → Information displayed in the today pane may become out of sync with current task/event information. This decoupling may lead unexpected behaviour including update or refresh errors when adding or modifying tasks or events in today pane.
(Reporter)

Comment 5

10 years ago
Hi,

  I have compiled the nightly Sunbird 1.0pre build from the mercurial repository, and confirm I am unable to reproduce this bug.

I sincerely apologize for your time; I should have checked to see if this bug was fixed first.

Regards,
Marking INVALID per bug reporter's comment 5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: mail-integration
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.