Move mouse to the unifinder, but not over an event -> error output

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Andreas Treumann, Assigned: Berend Cornelius)

Tracking

({regression})

unspecified
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- open the unifinder
- move the mouse over the unifinder, but not over an event!
- wait a moment, a small empty tooltip box comes up
- check the error console

RESULT:
=======

- output:

Error: aItem has no properties
Source File: chrome://calendar/content/mouseoverPreviews.js
Line: 74

EXPECTED RESULT:
================

- no output

REPRODUCIBLE:
=============

- always

Root cause is bug 449019
Flags: blocking-calendar0.9?
(Assignee)

Comment 1

10 years ago
Created attachment 334650 [details] [diff] [review]
patch v. #1

Added a verification if the item is null or not
Assignee: nobody → Berend.Cornelius
Status: NEW → ASSIGNED
Attachment #334650 - Flags: review?(philipp)

Updated

10 years ago
Attachment #334650 - Flags: review?(philipp) → review+

Updated

10 years ago
Blocks: 449019
The patch has already been checked in.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-calendar0.9?
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 3

10 years ago
Checked in lightning 2008082103 and sunbird 20080820 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.