Closed Bug 451498 Opened 16 years ago Closed 16 years ago

Double "Sent" Folder, Cannot be Deleted

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 286523

People

(Reporter: joseph.conner, Unassigned)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.16 (20080708)

Somehow, two "Sent" folders have been created.  One works as expected.  The other one refuses to be deleted.  I am submitting an annotated screen dump to illustrate what I am talking about.  I have no idea what caused the Sent to be double.  Nothing I have tried will delete the extraneous folder.

Reproducible: Always

Steps to Reproduce:
1.  Set focus bar to "Sent" folder.
2.  Press DEL
3.  
Actual Results:  
1.  Confirm dialog box pops up.  Choose OK
2.  Confirm dialog box disappears.  The Sent folder still exists.

Expected Results:  
Expected the folder to be deleted.  It did not.
(1) Check "folder location" of two "Sent" folders
    1. Open text editor
    2. "Copy Folder Location" of context menu of Sent folder(#1),
        and "Paste" to text editor
    3. "Copy Folder Location" of context menu of Sent folder(#2),
        and "Paste" to text editor
    What is difference?
(2) Check directory structure of directory for "Local Folders"
    1. Check Tools/Account Settings/Local Folders/Local directory:(say <path-x>)
    2. Create directory for directory listing by Command Prompt
       MD C:\WORK
    3. Get directory listing
       DIR <path-x> /S > C:\WORK\DIR-LIST.TXT
    4. NOTEPAD.EXE C:\WORK\DIR-LIST.TXT
    What directory/file is used for the duplicated "Sent" folders?
    (subfolder is held in \<parent_name>.sbd as <subfolder> & <subfolder>.msf)
Uploading text editor data and also directory data.
Double Sent folder Contexts.
Attached file Directory as requested
Directory dump
> SENT FOLDER #1
> mailbox:/C|/Documents and Settings/JOSEPH/Application Data/Thunderbird/MAIL/mailbox10b5ef27
> SENT FOLDER #2
> mailbox:/C|/Documents and Settings/JOSEPH/Application Data/Thunderbird/MAIL/Sent
> Directory of C:\Documents and Settings\JOSEPH\Application Data\Thunderbird\MAIL
>(snip)
> 06/21/2008  10:39 PM    <DIR>          mailbox10b5ef27
> 11/23/2008  02:16 PM             2,147 mailbox10b5ef27.msf
> 11/23/2008  02:02 PM    <DIR>          mailbox10b5ef27.sbd
>(snip)
> 11/14/2008  12:08 PM       214,407,078 Sent
> 11/23/2008  02:17 PM           690,518 Sent.msf
> 11/23/2008  02:02 PM    <DIR>          Sent.sbd

Who/How created DIRECTORY of "mailbox10b5ef27"?
In your previous screen shot, a subfolder named "Sent" is seen under the "Sent" folder(#1, garbage folder). This indicates that mail folder file of "Sent" existed under directory of "mailbox10b5ef27.sbd" when your problem occurred.
What did you do at 10:39 PM on 06/21/2008?

Fortunately, "mailbox10b5ef27" & "mailbox10b5ef27.sbd" are already empty directory. So "remove of garbage directories/files" can be a solution.
Please execute next for (A) recovery & (B) keeping data for problem analysis.
(1) Shutdown Thunderbird
(2) Create directory/file for "Garbage" folder in your mail directrory
>  C:\Documents and Settings\JOSEPH\Application Data\Thunderbird\MAIL
>     Garbage      <= a file without file extension, no data or null data.
>     Garbage.sbd  <= a directory
(3) Move "mailbox10b5ef27", "mailbox10b5ef27.msf", "mailbox10b5ef27.sbd" 
    under directory of "Garbage.sbd"
(4) Restart Thunderbird
(5) Dulplicated "Sent" problem is probably resolved.
(6) You can probably see mail folder for "mailbox10b5ef27" and
    "mailbox10b5ef27.msf" as subfolder of "Garbage".
    What is displayed as subfolder name by Thunderbird?
About name of mailbox10b5ef27 / mailbox10b5ef27.msf / mailbox10b5ef27.sbd :
Tb 2 generated file name of "mailbox10b5ef27" for mail folder of "mailbox:".

Did you create Virtual folder(Saved search folder) like "mailbox:/Sent" in the past?

Note:
Similar directory structure was very easily obtained by:
 (1) Create Virtual folder named "mailbox:/Sent" at a POP3 account
     mailbox10b5ef27.sbd (Directory) was created  
 (2) Shutdown Thunderbird, then restart Thunderbird
 (3) Following files/drectories were created 
       mailbox10b5ef27     ( <= Directory )
       mailbox10b5ef27.msf ( <= File      )
       mailbox10b5ef27.sbd\Sent     ( <= File )
       mailbox10b5ef27.sbd\Sent.msf ( <= File )
 (4) Folder pane display
     - mailbox: (as usual mail folder)
       - mailbox:Sent (as Virtual folder)
It's an variation of phenomenon of already known bug - Bug 286523.
If you renamed these corrupted folders, situation would be worse than direct result of Bug 286523, because "directory structure" and "folder<->file relation" were already corrupted sufficiently by Bug 286523.
QUESTION:  Who/How created DIRECTORY of "mailbox10b5ef27"?	In your previous screen shot, a subfolder named "Sent" is seen under the "Sent" folder(#1, garbage folder). This indicates that mail folder file of "Sent" existed under directory of "mailbox10b5ef27.sbd" when your problem occurred.  What did you do at 10:39 PM on 06/21/2008?
ANSWER:  I do not exactly know, it was quite by accident.  I have Thunderbird set up to manage four different email accounts.  I had been swapping about the account properties as to where to put sent mail, getting a feel for what would work best for me.
I can tell you, that the “Sent” sub-folder under "mailbox10b5ef27” can temporarily be deleted.  It goes to the trash folder.  Even after emptying the trash folder when nothing remains the "mailbox10b5ef27" sent folder refuses to respond to delete.  The option is greyed out.  The delete key is ignored.  Once Thunderbird is closed and reopened, the “sent” sub-folder reappears under the "mailbox10b5ef27" folder.
QUESTION:
Please execute next for (A) recovery & (B) keeping data for problem analysis.
(1) Shutdown Thunderbird
(2) Create directory/file for "Garbage" folder in your mail directrory
>  C:\Documents and Settings\JOSEPH\Application Data\Thunderbird\MAIL
>     Garbage      <= a file without file extension, no data or null data.
>     Garbage.sbd  <= a directory
(3) Move "mailbox10b5ef27", "mailbox10b5ef27.msf", "mailbox10b5ef27.sbd" 
    under directory of "Garbage.sbd"
(4) Restart Thunderbird
(5) Dulplicated "Sent" problem is probably resolved.
(6) You can probably see mail folder for "mailbox10b5ef27" and
    "mailbox10b5ef27.msf" as subfolder of "Garbage".
    What is displayed as subfolder name by Thunderbird?

ANSWER:  YES that did get rid of two “sent” folders.  The “garbage” folder is present, and under it is an empty subfolder “mailbox10b5ef27" and a sub-subfolder “Sent”.
QUESTION:  About name of mailbox10b5ef27 / mailbox10b5ef27.msf / mailbox10b5ef27.sbd :
Tb 2 generated file name of "mailbox10b5ef27" for mail folder of "mailbox:".

Did you create Virtual folder(Saved search folder) like "mailbox:/Sent" in the
past?

ANSWER:  I have done searches, including in the SENT folder, although I do not think that I have ever saved such a search.  I cannot guarantee this, as if I am tired or sleepy sometimes I do some strange things and later wonder why.  Usually it is just accidentally closing a window too soon.
Additional observation:  sub-subfolder “sent” will delete.  Neither Subfolder "mailbox10b5ef27" nor folder “garbage” will delete.  Closing and restarting Thunderbird shows the deleted “sent” folder back in its original position as a sub-subfolder under garbage.
(In reply to comment #9)
> Additional observation:  sub-subfolder “sent” will delete.
> Neither Subfolder "mailbox10b5ef27" nor folder “garbage” will delete.
> Closing and restarting Thunderbird shows the deleted “sent” folder back
> in its original position as a sub-subfolder under garbage.

It is perhaps a result of mail folder name(probably "Sent") which is somehow held in already corrupted "mailbox10b5ef27.msf".
To clear corrupted mail folders, do next.
  - Keep back up of Gargage.sbd directory
  - Delete Garbage, Garbage.msf, and Garbage.sbd, and restart Tb.

I close this bug as "DUP of Bug 286523" based on my test result of Comment #7.
If you need evidence of "DUP of Bug 286523", please attach backup of "mailbox10b5ef27.msf" to this bug. I'll check "mailbox10b5ef27.msf" content to guess what happened in the past.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: