The default bug view has changed. See this FAQ.

Remove |APP_XPCOM_LIBS| from /browser/

VERIFIED FIXED in Firefox 6

Status

()

Firefox
Build Config
--
trivial
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: Swatinem)

Tracking

Trunk
Firefox 6
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed by bug 648911], URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

9 years ago
Port |Bug 451871 – Remove |MOZILLA_INTERNAL_API| from /suite/| to Firefox.
(Assignee)

Comment 1

9 years ago
Created attachment 335506 [details] [diff] [review]
patch
[Superseded by bug 648911]

small patch to do the job.
Assignee: nobody → arpad.borsos
Status: NEW → ASSIGNED
Attachment #335506 - Flags: review?(ted.mielczarek)
Attachment #335506 - Flags: review?(ted.mielczarek) → review?(benjamin)
Attachment #335506 - Flags: review?(benjamin) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Note: bug 451871 got backed out because of tracemalloc bustage.
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> Note: bug 451871 got backed out because of tracemalloc bustage.

True, yet:
*The SM bustage still needs to be "confirmed" / narrowed down.
*Isn't Firefox already using |MOZ_ENABLE_LIBXUL| anyway ?
Depends on: 345517
Yes, but it's possible to build --disable-libxul, and debug builds disable libxul by default. (And tracemalloc probably doesn't work with libxul anyway.)
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Yes, but it's possible to build --disable-libxul, and debug builds disable libxul by default.

Ah... (Looking forward to "libxul only" (Firefox) ;->)

Then, someone needs to check a debug Firefox build.
Note that a debug SeaMonkey (without trace-malloc) build works fine with "this" patch.

> (And tracemalloc probably doesn't work with libxul anyway.)

Fwiw, as far as compiling and generating the logs, it works fine on my Windows (libxul SeaMonkey).
http://hg.mozilla.org/mozilla-central/rev/6772511dc81a
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b1
(Reporter)

Updated

9 years ago
Attachment #335506 - Attachment description: patch → patch [Checkin: Comment 6]
(Reporter)

Updated

9 years ago
Severity: normal → trivial
Flags: in-testsuite-
Depends on: 455095
Just backed this out, to see if it fixes bug 455095. (linux leak stats mysteriously all going to 0)

Backout was http://hg.mozilla.org/mozilla-central/rev/9d9569916616
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

9 years ago
Attachment #335506 - Attachment description: patch [Checkin: Comment 6] → patch [Backout: Comment 7]
This got fixed a while ago by bug 648911
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago5 years ago
Depends on: 648911
Resolution: --- → FIXED
Whiteboard: [Fixed by bug 648911]
(Reporter)

Updated

5 years ago
Attachment #335506 - Attachment description: patch [Backout: Comment 7] → patch [Superseded by bug 648911]
Attachment #335506 - Attachment is obsolete: true
(Reporter)

Comment 9

5 years ago
V.Fixed
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 3.1b1 → Firefox 6
You need to log in before you can comment on or make changes to this bug.