Closed Bug 455095 Opened 13 years ago Closed 13 years ago

"Linux mozilla-central leak test build" machine has been reporting 0 allocations since 09/08 04:31

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla3.1b1

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

(Keywords: regression)

The "mozilla-central leak test build" machine has been reporting 0 leaks and 0 allocations ("A: 0") since 09/08 04:31.

The last build with nonzero values, starting at 09/08 04:31, had:
  rev:48ca5b355829
  RLk:0B
  Lk:1.28MB
  MH:25.0MB
  A:783507

And the build after that, starting at 09/08 04:38, had:
  rev:6772511dc81a
  RLk:0B
  Lk:0B
  MH:0B
  A:0

and it's all 0's from there on out.

http://hg.mozilla.org/mozilla-central/rev/6772511dc81a (bug 451918) is the only checkin in the blame range, so it presumably changed something that broke leak stats.
Summary: "mozilla-central leak test build" machine has been reporting A:0 since 09/08 04:31 → "mozilla-central leak test build" machine has been reporting 0 allocations since 09/08 04:31
(In reply to comment #0)
> http://hg.mozilla.org/mozilla-central/rev/6772511dc81a (bug 451918) is the only
> checkin in the blame range, so it presumably changed something that broke leak
> stats.

I just backed that out, to see if it fixes this.
The backout is http://hg.mozilla.org/mozilla-central/rev/9d9569916616
Yup, that backout seems to have fixed it.

The first build after the backout has:
RLk:0B
Lk:1.28MB
MH:25.3MB
A:780342
Assignee: nobody → dholbert
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Only "Linux mozilla-central leak test build" showed this.

"OS X 10.5.2 mozilla-central leak test build"
and
"WINNT 5.2 mozilla-central leak test build"
still reported fine.

*****

Fwiw,

See bug 451871 too ... in which an issue was reported to brake Linux ... but
which I couldn't reproduce on my local Windows.

Per bug 451918 comment 4 hint,
there may be something wrong with trace-malloc, but on Linux only ?!
Blocks: 451871
Summary: "mozilla-central leak test build" machine has been reporting 0 allocations since 09/08 04:31 → "Linux mozilla-central leak test build" machine has been reporting 0 allocations since 09/08 04:31
Target Milestone: --- → Firefox 3.1b1
If you cc: me on a bug, it's helpful to know why.
Component: Build Config → General
Product: Firefox → Firefox Build System
Keywords: regression
Target Milestone: Firefox 3.1b1 → mozilla3.1b1
You need to log in before you can comment on or make changes to this bug.