TM: Crash [@ TraceRecorder::record_JSOP_GETELEM() ] in SM when try to open Chatzilla

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tobias Fischer, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080823003118 Mnenhy/0.7.5.20005 SeaMonkey/2.0a1pre

Try to open ChatZilla in SeaMonkey Trunk with JIT for chrome enabled:
"javascript.options.jit.chrome"  "true" 
(and for ..jit.content too) crashes SeaMonkey at:

[@ TraceRecorder::record_JSOP_GETELEM() ]

Some Crash-Report IDs:
6ac05391-71d0-11dd-a3c8-001a4bd43e5c
87ddadbd-71d0-11dd-a432-001a4bd43ef6
91cebba3-71d0-11dd-a9f8-001a4bd43ed6

Updated

10 years ago
Duplicate of this bug: 451954

Comment 2

10 years ago
There is a stack in bug 451954
(Reporter)

Comment 3

10 years ago
Changing OS=All, because this crashes on Linux (Thanks Smaug, sometimes it takes some time, before new Reports shows up in Bugzilla)) and MacOS X too.

And a new Crash-Report from Todays Nightly:
http://crash-stats.mozilla.com/report/index/8fe1a730-71f0-11dd-9bc5-001cc45a2c28

And to test the Crash-Reporter linkage in Bugzilla (need bp- prefix?), another one, Crash ID: bp-71bda280-7202-11dd-b1f2-0013211cbf8a
OS: Windows XP → All
Depends on: 451983
No longer depends on: 451983
(Reporter)

Comment 4

10 years ago
Note: MacOS X seems to be *not* affected by this issue. 

I have tested again with 2008-08-24-05 Nightly Build on MacOS X 10.4.x and can't reproduce the crash anymore. Earlier I got one crash with an Tinderbox-Build (so no Crash-Report), but it seems to be caused by an other issue. ChatZilla, and ChatZilla-Preferences are runnig fine on MacOS X 10.4.x with JIT chrome (and content) enabled. Sorry for to less testing. 

So the crash was only confirmed for Windows and Linux-Builds at moment.
(Reporter)

Comment 5

10 years ago
Humm, using the 2008-08-26-xx-xx Nightly on MacOS X 10.5.x (current Version) with Intel MBP I can reproduce the Crash opening ChatZilla. But not under MacOS X 10.4.xx with G4 iBook. Will submit the Crash-ID from MacBook Pro later.
(Reporter)

Comment 6

10 years ago
WFM now using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080903054738 Mnenhy/0.7.5.20005 SeaMonkey/2.0a1pre

Also no crash with yesterdays Nightly under MacOS X 10.4.x, have not tested MacOS X 10.5.x yet, will try it later. If there is no crash under Linux anymore, this should be closed as wfm.
(Reporter)

Comment 7

10 years ago
Todays SeaMonkey-Nightly on MacOS X 10.5.x will not crash too, so resolved=worksforme now. 
Please reopen, if you still ran into the crash with an current Build.
Blocks: 453668
No longer blocks: 451602
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.