crash on startup of 3.0.1 after upgrade from 2.0.0.16

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: donguana, Unassigned)

Tracking

({crash})

3.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

157.83 KB, application/x-zip-compressed
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 ...... Firefox/3.0.1

After upgrading to 3.0.1 I cannot startup Firefox.  It always crashes.
I have tried starting up in safe mode (disabling and reseting everything)
I have also tried removing my profile folder (Application Data/Mosilla) thinking that it would recreate it.
I had also tried upgrading to 3.0.0 when it was first released and got the same problem.
I always get the crash report and it always fails to send the crash report so I thought I would post the crash reports here.

Reproducible: Always

Steps to Reproduce:
1. upgrade/install 3.0.1
2. attempt to startup firefox
3.
Actual Results:  
I get a crash reports

Expected Results:  
Firefox would startup
(Reporter)

Comment 1

10 years ago
Created attachment 335517 [details]
crash reports related to bug
Can you try to start Firefox with a different Profile , see http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

A crash report ID from the Firefox Crash Reporter would help us too. 
Keywords: crash
Version: unspecified → 3.0 Branch

Comment 3

10 years ago
Mine is exactly the same.

I want action on this immediately.  The upgrade has not only left me without Firefox but Internet explorer crashes in the same way too.

The only way I have managed to get online to send this is using Safari

This is the crash report, which I don't think is being sent!

BuildID: 2008070208
CrashTime: 1219826954
InstallTime: 1219794278
ProductName: Firefox
SecondsSinceLastCrash: 537
StartupTime: 1219826609
Theme: classic/1.0
URL: 
UserID: f61caf9a-c1a1-44c3-ac32-d9ffeb2469a5
Vendor: Mozilla
Version: 3.0.1

This report also contains technical information about the state of the application when it crashed.

Comment 4

10 years ago
I have since uninstalled 3.01 and reinstalled the previous version.

You can get links to old downloads here http://www.mozilla.com/en-US/firefox/all-older.html

Interestingly Internet Explorer is still crashing in the same way, so I am assuming that Mozilla has somehow modified a file that affects both browsers.

I am writing to Microsoft on this matter and I'm sure they will be interested to know what is happening here.
(Reporter)

Comment 5

10 years ago
Re comment #2

I followed the instructions for a "Clean reinstall" from that link and that fixed my problems. Thank you very much :)

I had tried all these steps before except for deleting the content from "C:\Program Files\Mozilla Firefox" after the uninstall.

I think I would like to see a feature where there should be an option in the uninstall process to remove profiles and plugin which should completely delete the "C:\Program Files\Mozilla Firefox" folder and the "../Application\Data\Mozilla\Firefox/" folder as well. This may avoid annoying bugs like this one.

Is anyone interested in looking at the content of the old "C:\Program Files\Mozilla Firefox" from version 2 before I deleted it as this might help locate the core problem? I backed it up before deleting it. If not then this bug can be closed.

Thanks.
(Reporter)

Comment 6

10 years ago
Problem solved. 

The cause of the problem is not solved. But it may get solved in bug 113593.

Closing bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Depends on: 113593
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.