Closed Bug 113593 Opened 23 years ago Closed 15 years ago

uninstall doesn't remove all files

Categories

(SeaMonkey :: Installer, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

Details

after the "inspector" where added to the install, this file:
c:\Program 
Files\mozilla.org\Mozilla\chrome\overlayinfo\inspector\content\overlays.rdf
doesn't get deleted when uninstalling mozilla.

uninstall also leaves this file:
c:\Program Files\mozilla.org\Mozilla\chrome\chrome.rdf
and this directory:
c:\Program Files\mozilla.org\Mozilla\components\Netscape\
behind.

build 20011203
*** Bug 114599 has been marked as a duplicate of this bug. ***
reassigning
Assignee: syd → curt
Target Milestone: --- → Future
see also Bug 125877 
*** Bug 135642 has been marked as a duplicate of this bug. ***
Looks like this bug calls for only two more files to be deleted.
uninstall on Windows also doesn't remove:
%WINDIR%\MozillaUninstall.exe
%WINDIR%\mozver.dat
%WINDIR%\nsreg.dat [bug 142367]

we ask people to remove these by hand when they uninstall - this should not be
the user's responsibility but the mozilla uninstaller's
mozver.dat is shared between multiple mozilla instances

nsreg.dat is a mistake in the first place.

The uninstaller should probably remove itself after it's done successfully. It
can also be shared between multiple mozilla instances so it'd need to check the
registry first to see if other Mozillas are registered.
Keywords: nsbeta1nsbeta1-
we also miss "compreg.dat"
Blocks: 165604
Blocks: 165199
If the uninstall routine were properly implemented, we wouldn't have to worry
about bug 162593 or bug 165199.
Blocks: compreg.dat
Not sure what exactly should be removed. Certainly everything which has
significant information MUST NOT be removed. Is it true, that all those things
are in the user profile directories? Well, no, at least the plugins are not.
Anything else?

pi
No longer blocks: 165604
I'm upgrading this to Major based on Bug #165199 where it was demonstrated that
this bug prevented Mozilla from being usable (even after uninstalling the
previous version).
Severity: normal → major
Keywords: mozilla1.0.1mozilla1.2
doing a Mozilla install (20020904) on a clean system leaves these file behind 
when doing a uninstall:

C:\Program 
Files\mozilla.org\Mozilla\chrome\overlayinfo\cookie\content\overlays.rdf
C:\Program 
Files\mozilla.org\Mozilla\chrome\overlayinfo\inspector\content\overlays.rdf
C:\Program Files\mozilla.org\Mozilla\components\compreg.dat
C:\Program 
Files\mozilla.org\Mozilla\components\Netscape\MozillaTrunk\manifest.ini
C:\Program 
Files\mozilla.org\Mozilla\components\Netscape\MozillaTrunk\permdata.box
C:\WINNT\MozillaUninstall.exe
C:\WINNT\mozver.dat

And we still leave a whole stuff in the reg.db behind. Please see bug 125877 
for that...
Depends on: 125877
This seems like a serious problem because it is impossible to have a clean
install afterwards. The old problems are moved onto the new installation. 
This blocks bug 171441 too.
I'm not sure if technically, this blocks Bug #171441, or that bug is a dup of
this one. For now, I'm going to mark it as being blocked by this one.
Keywords: mozilla1.2mozilla1.3
*** Bug 135017 has been marked as a duplicate of this bug. ***
I'm removing the block on Bug #171441 that I added earlier. Two reasons, that
bug has been fixed, and it also (sort of) deals with the COMPREG.DAT file
mentioned in Comment #12 (by deleting it on install). Mind you, if it deletes it
on install, then it's perfectly valid to delete it on uninstall as well.
No longer blocks: CouldNotBeRead
Blocks: 195818
Product: Browser → Seamonkey
Also talkback is left behind when uninstalling. I think uninstaller should ask
you if you like your profile deleted or not. Also if to delete the install dir
which likely contains plugins + etc stuff not installed by original Firefox
install. Non-functional uninstallers are very annoying.
QA Contact: bugzilla → general
Blocks: 379157
Assignee: curt → nobody
Target Milestone: Future → ---
Blocks: 452219
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.