FeedConverter.js: QueryInterface should throw NS_ERROR_NO_INTERFACE

RESOLVED FIXED in Firefox 3.1b1

Status

()

Firefox
RSS Discovery and Preview
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: WeirdAl, Assigned: philor)

Tracking

Trunk
Firefox 3.1b1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
http://hg.mozilla.org/mozilla-central/index.cgi/annotate/43e89bd626d2/browser/components/feeds/src/FeedConverter.js#l525

Not nice to throw NS_ERROR_NOT_IMPLEMENTED in a QI call.
(Assignee)

Comment 1

9 years ago
Created attachment 340769 [details] [diff] [review]
Fix

Well, see, there were going to be all these other fun things you could QI to, but they weren't implemented yet...
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #340769 - Flags: review?(gavin.sharp)
Attachment #340769 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 2

9 years ago
http://hg.mozilla.org/mozilla-central/rev/e20c3b2df713
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b1

Updated

8 years ago
Duplicate of this bug: 499568
You need to log in before you can comment on or make changes to this bug.