Keyboard accelerator does not work in account wizard

RESOLVED FIXED

Status

Thunderbird
Account Manager
--
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Scott Dodson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080723) (Fedora 9)

When creating an account, on the third pane pressing alt-i does not select imap as the server type. Pressing alt-p does select pop however.

Reproducible: Always

Steps to Reproduce:
1. Go to Account Settings
2. Add Account
3. Fill out the first two panes
4. Attempt to switch the server to imap by pressing the indicated keyboard accelerator (alt-i)
Actual Results:  
Nothing

Expected Results:  
Server type is toggled to IMAP

Comment 1

10 years ago
Confirmed.  The POP accelerator works, but the IMAP one doesn't.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed in what version (and on what platform)? It WFM in trunk/Windows, which I suspect is due to bug 143065: a wizard is a deck under the covers and there's a second "I" accesskey for "Incoming User Name" (and has been since bug 201469 landed five years ago, without any sign of anyone noticing until now, something I'm going to be keeping in mind during accesskey arguments :).

Comment 3

10 years ago
Sorry, 2.0.0.16 on Windows has this problem.

Comment 4

10 years ago
The fact that the right arrow key works as a trivial workaround even when a mouse isn't present probably helped reduce the flurry of bug reports.  :-)
Thanks. Fixed by bug 143065 (and unfixable in 2.x, since it would require changes to frozen strings) then.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.