Using Vista, Firefox drops a whole bunch of files/icons on the desktop and leaves them there even after Firefox is closed.

RESOLVED DUPLICATE of bug 302087

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 302087
11 years ago
11 years ago

People

(Reporter: daveclarkemora, Unassigned)

Tracking

1.9.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Some example file names: places.sqlite, compreg.dat, XPC.mfl, 

Reproducible: Always

Steps to Reproduce:
1.Open Firefox on Vista.
2.
3.
Actual Results:  
This Toshiba laptop is less than 10 days old. I download the latest version of Firefox. It successfully installs and once I either minimize the window or close Firefox, there are all those files, about two dozen of them. I have uninstalled and reinstalled several times. This is happening on one of the computer's user's account, "Admin," but if I switch users to Guest, it doesn't happen for that user.

Expected Results:  
No stuff left behind on my desktop when I use Firefox.

As above.
Installer doesn't do anything with profiles which is what is happening here... over to startup and profile system for further triage
Component: Installer → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: installer → startup
Version: unspecified → 1.9.0 Branch
Firefox apparently thinks that your desktop is your profile folder.
What if you create a new profile? Click Start -> Run and type firefox -p
If you want a different location then default, first make a new empty folder on that location.
Reporter

Comment 4

11 years ago
Hi,

I did make a new profile and it did remove all the files from my desktop, BUT... I don't know how there could be a connection yet, subsequently, files not related to Firefox also were removed, not only from my desktop, but the entire hard drive (personal Word docs, 4000+ pictures, iTunes, etc.).

I can restore them from a backup, but they just disappeared apparently...

Any thoughts?
I should have warned you more explicitly about the danger that the Profile Manager would delete the whole profile folder (in your case the desktop) but it didn't cross my mind. I thought you would reuse those files in your new profile and delete them manually from your desktop.

I think this is a case similar to Bug 278230, Bug 340457 or Bug 302087.
Reporter

Comment 6

11 years ago
Uh...yeah, that (warning) would've been very helpful. :-)

thx.

d.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 302087
You need to log in before you can comment on or make changes to this bug.