Closed Bug 452495 Opened 11 years ago Closed 11 years ago

TM: Crash [@ TraceRecorder::getThis] with |new|

Categories

(Core :: JavaScript Engine, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: jruderman, Assigned: gal)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Crash Data

Attachments

(1 file)

./js -j
js> for (var j = 0; j < 4; ++j) { try { new 1(this); } catch(e) { } }

Crash [@ TraceRecorder::getThis] dereferencing 0xfffffffc

Tracemonkey branch revision 90bb1fa51f16, which includes brendan's changeset eee9a90b81cb "Fix a bug Jesse reported: insufficient copy/paste from record_JSOP_CALL to record_JSOP_NEW".  That changeset fixed an assertion with a related testcase, but apparently it didn't fix this crash.
Comment 1 is in the wrong bug.
Assignee: mrbkap → danderson
Can no longer reproduce -- looks like we correctly abort now.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Still crashes for me on tracemonkey branch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Crash [@ TraceRecorder::getThis] with |new| → TM: Crash [@ TraceRecorder::getThis] with |new|
Assignee: danderson → gal
Duplicate of this bug: 453050
Is it actually crashing while trying to evaluate the truthiness (??) of that assertion?
No, the this caused it IMO.
Attachment #338882 - Flags: review?(brendan) → review?(danderson)
Attachment #338882 - Flags: review?(danderson) → review+
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-452495.js,v  <--  regress-452495.js
initial revision: 1.1

http://hg.mozilla.org/mozilla-central/rev/d8cf927f80be
Flags: in-testsuite+
Flags: in-litmus-
Status: RESOLVED → VERIFIED
Crash Signature: [@ TraceRecorder::getThis]
You need to log in before you can comment on or make changes to this bug.