Last Comment Bug 452578 - [mai] Registration for Firefox and Thunderbird for Maithili language
: [mai] Registration for Firefox and Thunderbird for Maithili language
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
:
Mentors:
Depends on:
Blocks: fx-l10n-mai
  Show dependency treegraph
 
Reported: 2008-08-28 01:34 PDT by Rajesh Ranjan
Modified: 2011-03-11 04:12 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Maithili (mai) Translation (278.02 KB, application/zip)
2010-01-20 01:22 PST, Rajesh Ranjan
l10n: review+
Details

Description Rajesh Ranjan 2008-08-28 01:34:19 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070718 Red Hat/1.5.0.12-3.el5 Firefox/1.5.0.12 pango-text
Build Identifier: 

Maithili (mai-IN) is one of the most important language spoken in the eastern
part in India. This in one of the scheduled language by government of India. So
I am eager to start the localisation process for the language.  

http://www.mithilaonline.com/maithili.html

http://en.wikipedia.org/wiki/Maithili

My name is Rajesh Ranjan. Email Address: rajeshkajha@yahoo.com Address:

Nilgiri-203, Kubera Sankul, Hadapsar, Pune-411028. India.

website: http://maithili.sf.net

Ref: Bug #344081 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Rajesh Ranjan 2008-11-04 22:00:26 PST
ping!
Comment 2 Simon Paquet [:sipaq] 2009-03-15 08:15:34 PDT
Hi Rajesh,

I hope you are doing well.  I am not sure where you are in your localization
effort at this time.  Have you begun work on Firefox 3 / Thunderbird 2 or have you already moved towards Firefox 3.1 (soon to be rebranded as Firefox 3.5) and Thunderbird 3?  

If the former, may I suggest that move towards localizing for Firefox 3.1 / Thunderbird 3 because these will probably become the stable releases once you are finished with your localization.

If you are interested in moving your effort toward localizing Firefox
3.1 / Thunderbird 3, then you can read the following documentation on working with Mercurial and getting a local environment set up on your machine.

http://developer.mozilla.org/en/L10n_on_Mercurial

or learn the basics about Mercurial here:

http://developer.mozilla.org/en/Mercurial

Some additional information for Thunderbird localizers is here:

https://wiki.mozilla.org/Thunderbird:Localization

Thanks so much for your hard work.  As always, ping us with any questions, we
are ready to help.

I'm also adding some people from the Firefox l10n team (I'm the Thunderbird l10n lead) to this bug report, as it seems that people didn't notice this report in time.
Comment 3 Rajesh Ranjan 2009-03-17 03:59:13 PDT
Hi Simon!

Thanks for replying the long awaited bug (6 month). 

The Maithili language community is doing things for Firefox and after completing we will do for Thunderbird as well. 

We will try to finalize for ff3.1 for Maithili language and soon we will submit translated file. Soon after that we will do Maithili Thunderbird as well because we need to have one email client as well.

Maithili is one of the fastest growing community of India simultaneously working for Gnome, Fedora, Kde. We were waiting for long time but didn't get eny reply from here. 
Anyway, its never too late!
Comment 4 Simon Paquet [:sipaq] 2009-03-17 05:26:55 PDT
(In reply to comment #3)
> Hi Simon!
> Thanks for replying the long awaited bug (6 month).

Hi Rajesh, sorry for the long wait. I guess this happened because this bug was originally filed in Mozilla Localizations/Other, which is not actively watched by many people.

I know that the Firefox l10n team actively watches the "Registration & Management" component, so response times should improve significantly from now on.

I'm glad to hear that you are still committed to localizing Firefox and Thunderbird into Maithili. Sorry again for the late response.
Comment 5 Seth Bindernagel 2009-03-17 10:10:45 PDT
Thank you, Simon, for following up with Rajesh!  :)

Rajesh, Simon has pointed you to some very good documentation above.  I also blogged recently about helpful documentation for Mozilla l10n (specifically relating to Firefox).  

http://blog.mozilla.com/seth/2009/03/05/helpful-mozilla-localization-documentation/

Please do review those pages as you prepare your translation.  We will need to file a tracking bug that will have several dependent bugs relating to finishing your localization.  Also, if you have not already, consider joining the mozilla.dev.l10n newsgroup here:  http://groups.google.com/group/mozilla.dev.l10n/topics?lnk=srg

We'll look forward to your finished translation and please ask us any questions along the way.
Comment 6 Rajesh Ranjan 2009-03-18 04:09:48 PDT
Thanks Simon and Seth! 
We will soon come with the finished translation.
Comment 7 Simon Paquet [:sipaq] 2009-06-06 23:53:33 PDT
(In reply to comment #6)
> Thanks Simon and Seth! 
> We will soon come with the finished translation.

Rajesh, any news? What has happened with regards to the Maithili localization of Firefox and Thunderbird within the last 2.5 months?
Comment 8 Simon Paquet [:sipaq] 2009-10-07 05:42:26 PDT
Rajesh: ping!
Comment 9 Rajesh Ranjan 2009-10-07 06:27:47 PDT
I am sorry from my side for late. Actually work more or less in its final phase and hopefully Maithili community will give all translated things in next two weeks. In India it is festival season, community was having pressure on already started project like GNOME and Fedora and all were having almost same freeze date. 
Soon, Maithili firefox and thunderbird will be available.
Comment 10 Rajesh Ranjan 2009-11-25 23:11:25 PST
Sorry For the late. Maithili Team is ready with translation of Firefox. Please let us know how to proceed further for Maithili language here.
Comment 11 Gen Kanai [:gen] 2009-11-25 23:48:24 PST
Rajesh, can you please attach the file to this bug or point us to a url where we can see what has been completed?  We can then provide next steps.
Comment 12 Rajesh Ranjan 2009-11-26 10:50:31 PST
Thanks! Gen, Please download from here: 

http://bhashaghar.googlecode.com/files/maithili-firefox-3.6.zip

It is complete translation. Please check and let us know.
Comment 13 Rajesh Ranjan 2009-11-26 11:27:02 PST
Gen, In this Mail and Editor folders are not present. As already mentioned it is only for Firefox. Later after firefox we will submit Thunderbird.
Comment 14 Gen Kanai [:gen] 2009-11-26 14:43:38 PST
Thank you Rajesh.  You can file a separate bug for Thunderbird- that would be preferred.  Please let the l10n team evaluate your translation file first. There may be a slight delay as some people are off on vacation in the US (Thanksgiving.)
Comment 15 Rajesh Ranjan 2010-01-17 23:50:00 PST
Please update me about the status!
Comment 16 Axel Hecht [:Pike] 2010-01-19 09:28:04 PST
Rajesh, can you do me a favour and attach that to this bug and request review from me? That way, it'll show up in our queue.
Comment 17 Rajesh Ranjan 2010-01-20 01:22:46 PST
Created attachment 422504 [details]
Maithili (mai) Translation

Thanks! Attaching the same here as well. 
Please do the review of the same and let me know to proceed!
Comment 18 Axel Hecht [:Pike] 2010-04-20 03:40:20 PDT
Comment on attachment 422504 [details]
Maithili (mai) Translation

r=me, I'm having a few nits, but those don't block review.

Do you guys already have an hg repo locally? Or should I bootstrap one?

I'll be filing the follow up bugs in a few.
Comment 19 Axel Hecht [:Pike] 2010-04-20 03:52:44 PDT
Also, could you add a bit more information to https://wiki.mozilla.org/L10n:Teams:mai so that people just need to look at that page instead of clicking through to this bug?
Comment 20 Rajesh Ranjan 2010-04-21 02:14:00 PDT
(In reply to comment #18)
> (From update of attachment 422504 [details])
> r=me, I'm having a few nits, but those don't block review.
> 
> Do you guys already have an hg repo locally? Or should I bootstrap one?

Thanks a lot Pike!  Please do for us.
Comment 21 Rajesh Ranjan 2010-04-21 02:14:54 PDT
(In reply to comment #19)
> Also, could you add a bit more information to
> https://wiki.mozilla.org/L10n:Teams:mai so that people just need to look at
> that page instead of clicking through to this bug?

Added initial info!
Comment 22 Axel Hecht [:Pike] 2011-03-11 04:12:28 PST
This can be resolved now, we have maithili builds for download on http://www.mozilla.com/en-US/firefox/all-beta.html#mai.

Note You need to log in before you can comment on or make changes to this bug.