RFE: smart autoscrolling by middle click on scrollbar in firefox

VERIFIED DUPLICATE of bug 452606

Status

()

VERIFIED DUPLICATE of bug 452606
11 years ago
11 years ago

People

(Reporter: mcepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072301 Fedora/3.0.1-1.fc10 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072301 Fedora/3.0.1-1.fc10 Firefox/3.0.1

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=460522)

I have a good idea for better firefox UI

it's to make middle click assigned to autoscrolling only in the scrollbar
region
so that it won't interferes with what ever Linux users do with there middle
mouse button

most people are not aware that firefox do have autoscrolling
and even when they know about it, they will disable it back
because we need to copy and paste with middle mouse button
and we do other things with it

http://fedoraproject.org/wiki/FWN/Issue138#Firefox_Mouse_Woes

middle clicking the scrollbar is not strange it's there in other web browsers
like IE and opera

and to make Windows users happy this limiting the autoscrolling region should
be only defaults in linux

ie. instead of having autoscrolling on and off
we should have autoscrolling full or smart (or limited)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452606

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.