Formatting (Bold/italic/underline) when composing an email or using composer (in SM) broken - can't type characters

RESOLVED DUPLICATE of bug 314160

Status

()

Core
Widget: Cocoa
P2
normal
RESOLVED DUPLICATE of bug 314160
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: smichaud)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---
Bug Flags:
wanted1.9.1 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
Open up a new mail, or in SM's web page composer:

- type some letters
- click bold, italic or underline
- try to type some more letters

Can't type more letters. Trying to move the cursor cancels the selection, the only way to get appropriately formatted text is to actually click precisely on the cursor so that it doesn't move off the character. Then you can type some characters in the appropriate font until the next change.
Flags: blocking-thunderbird3+
(Reporter)

Updated

9 years ago
Priority: -- → P1

Comment 1

9 years ago
I can't reproduce this in my 24hr old Windows build.

Is the midas demo broken too? (You can of course try that in Firefox.)
Both the midas demo and Tbird compose WFM on today's Windows builds. What has Widget:Cocoa done to us lately? (It is lately, isn't it? I don't compose HTML on Mac often enough to say within a month.)
And yes, the midas demo is broken in trunk Firefox on Mac.
Probably not lately: near as I can tell, it hasn't worked since the widget:cocoa switch. Worked in my last nococoa build in November 2006, failed in a cocoa build from the same tree, but from 2006-09-29 to 2008-01-17 and then 2008-02-13 to 2008-02-26 we had the "clicking anything in the toolbar unfocuses and disables the toolbar" thing from bug 357535, which makes it harder to follow in Thunderbird.

In Firefox looking at the Midas demo, before 2008-01-17 and from 2008-02-13 to 2008-02-26 clicking the Bold button without a selection takes the caret out of the textarea, while from 2008-01-17 to 2008-02-13 and from 2008-02-26 to now it leaves a caret without the ability to type anything.
(Assignee)

Comment 5

9 years ago
Yup, this is a Cocoa widgets bug -- a very old one.

Like Phil, I see it starting (in one form) with the
2006-09-29-06-trunk Minefield nightly (where Cocoa widgets was first
turned on by default).  I also see it in Camino 1.6.X (which uses an
ancient, pre-1.9 variety of Cocoa widgets), and in current
1.9.0-branch Camino nightlies.

This shouldn't be P1 or a blocker -- it's gone for a very long time
without being noticed.
Assignee: nobody → joshmoz
Component: Composition → Widget: Cocoa
Flags: blocking-thunderbird3+
Product: MailNews Core → Core
QA Contact: composition → cocoa
Target Milestone: Thunderbird 3.0b1 → ---
(Assignee)

Updated

9 years ago
Assignee: joshmoz → smichaud
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
Priority: P1 → P2
(Assignee)

Comment 6

9 years ago
(Following up comment #5)

Forgot to mention that I tested with the Midas demo (http://www.mozilla.org/editor/midasdemo/).
(In reply to comment #5)
> This shouldn't be P1 or a blocker -- it's gone for a very long time
> without being noticed.

I know this is filed somewhere, or at the very least I've commented about it in another bug....
Whiteboard: DUPEME
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314160
Whiteboard: DUPEME
Flags: wanted1.9.0.x?
You need to log in before you can comment on or make changes to this bug.