Format Text Buttons in Mail Composer Windows don't work

VERIFIED FIXED in mozilla1.9beta4

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
12 years ago
10 years ago

People

(Reporter: quicksilver8, Assigned: Nick Kreeger)

Tracking

({regression})

Trunk
mozilla1.9beta4
All
Mac OS X
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061021 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061021 SeaMonkey/1.5a

If I open a new mail message window and compose some text, if I want to format it, after selecting it, if I press format buttons within formatting text bar, they don't work. Instead, they become blurred. The only way to format text is via command keyboard: they work correctly.

Reproducible: Always

Comment 1

12 years ago
Do you see any error in the Error Console (Tools->Web Development->Error Console) when clicking on such a button?
(Reporter)

Comment 2

12 years ago
I see this message in Error Console: Warning: Key event not available on GTK2: key="a" modifiers="accel, shift"
Source File: chrome://messenger/content/messengercompose/messengercompose.xul
Line: 0

Comment 3

12 years ago
That one is not related.

Comment 4

12 years ago
--> Confirm

Thunderbird of trunk reproduces. 
And the button and the selection menus other than the color become insensitive. 

It might be an influence that changes into Cocoa widget in bug326469. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

12 years ago
Component: MailNews: Main Mail Window → Widget: Cocoa
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk

Updated

12 years ago
Assignee: mail → joshmoz
QA Contact: cocoa
(Reporter)

Comment 5

12 years ago
This bug never gone. It still alive. I repeat, formatting text in new message window works only with command keys. Buttons are dead.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
(In reply to comment #5)
> This bug never gone. It still alive. I repeat, formatting text in new message
> window works only with command keys. Buttons are dead.

Huh? Do you mean to say it is fixed (that it works now) or that you can still reproduce it?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

12 years ago
It still reproduces. 
It has not solved it yet. 

Mac OS X 10.3.9
trunk Thunderbird version 3 alpha 1 (20061115)
Duplicate of this bug: 385506
Status: REOPENED → NEW
Flags: blocking1.9?
Blocks: 326469
Duplicate of this bug: 394794

Comment 11

11 years ago
The COLOR choice button works man!

:)

Updated

11 years ago
Duplicate of this bug: 357408

Updated

11 years ago
Blocks: 370726

Comment 13

11 years ago
I can reproduce this with latest trunk thunderbird on 10.4. No console output.

I am not going to mark this blocking yet because there is no evidence that it is actually a cocoa widget bug. Can somebody investigate and see if this is really a widget bug?

Updated

11 years ago
Assignee: joshmoz → nick.kreeger
From bug 385506 comment 6:

Works in:
Thunderbird 2006092804
SeaMonkey 2006092806

Does not work in:
Thunderbird 2006092908
SeaMonkey 2006092906
Keywords: regression
(Assignee)

Comment 15

11 years ago
I'm seeing alot of this when I have focus in the text-editor of the composer window and I try to click on the formatting tab:

###!!! ASSERTION: cannot call on a dirty frame not currently being reflowed: '!NS_SUBTREE_DIRTY(this) || (GetStateBits() & NS_FRAME_IN_REFLOW)', file /Users/nickkreeger/Projects/tbird_trunkdebug/mozilla/layout/generic/nsFrame.cpp, line 556


I don't see any of this verbiage on my debug Windows and Linux (Ubuntu) builds....
I'll keep investigating.
(Assignee)

Comment 16

11 years ago
(In reply to comment #14)
> From bug 385506 comment 6:
> 
> Works in:
> Thunderbird 2006092804
> SeaMonkey 2006092806
> 
> Does not work in:
> Thunderbird 2006092908
> SeaMonkey 2006092906
> 

Judging by these dates... I think it is related to enabling cocoa-widgets:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=joshmoz%25gmail.com&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-09-28&maxdate=2006-09-29&cvsroot=%2Fcvsroot

I'll keep investigating. 

Comment 17

11 years ago
Please re-nominate this bug for blocking status when we know more about the cause of this.
Flags: blocking1.9? → blocking1.9-
Duplicate of this bug: 404012

Comment 19

11 years ago
Having same sitch but only with version 3.0a1pre (2007112403).  In 2.0.0.9, I can use buttons or keybd shortcuts.  In version 3.0a1pre (2007112403), if I click, for example, the B button, it just greys out w/ no bolding of the selected test. BUT if I use CMD-B I'm fine.

I did as suggested in another post and removed MimeTypee.rdf from the Library and it has no content and removing it makes no difference.  Me not smart enuf to do other fansee mods 'n' stuff w/out supervishon.

NO TROUBLE W/ SEA MONKEY SeaMonkey 1.1.6:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071030 SeaMonkey/1.1.6

May I briefly mention here that the other main thing I miss from Eudie is that Tbird doesnt quote the original header or at least give the date and time of the previous content?

Thanks for all ur hard work on this project. Hope I can help in a small way - pls ask what I can do to test for you to clear this up.

Phil

Am THRILLED that v3 will allow pasting screenshots directy to body - one of themain things I miss vs Eudora Mac 6.2.x but Eudie did terrible HTML so my hopes are on Tbird.
(Assignee)

Comment 20

11 years ago
There is a fix for this on bug 403232

Updated

11 years ago
Depends on: 403232
My patch for bug 403232 has just landed ... so I assume this bug is
now fixed, too.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED

Comment 22

11 years ago
Reopening as bug 403232 was reopened.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 411204
(Following up comment #21)

The first time I landed a patch for bug 403232, I had to back it out
because of Mochitest failures.  I've just landed another version of
the patch, which had no problems.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED

Comment 25

11 years ago
Verified fixed with Mac Thunderbird version 3.0a1pre (2008011803). Thanks, Steven!
Status: RESOLVED → VERIFIED
And back again. 20080214, 13, or 12. I'll figure out which later today unless someone already knows and is working on it somewhere else. :(
Looks like mozilla/widget/cocoa/nsChildview.mm rev 1.306 (smichaud%pobox.com 2008-02-13 07:57) is what did it. I reverted to 1.305 in my src and now everything is working again in Thunderbird when I click the format bar.
Jay, can you file a new bug on that and CC smichaud?
Done, Bug 418031 filed.
I've just posted a patch for bug 404433 that also fixes bug 418031 (at
least in my tests).  Please try it out.

If need be I can upload a Thunderbird build made using this patch to
my people.mozilla.com account and provide a URL for that here.

Presuming I've figured out how to do a universal build of Thunderbird
:-)
I just landed a patch for bug 404433 that also fixes this bug.
Hardware: Macintosh → All
Target Milestone: --- → mozilla1.9beta4

Updated

10 years ago
Duplicate of this bug: 419436

Updated

10 years ago
Duplicate of this bug: 365053
You need to log in before you can comment on or make changes to this bug.