Closed Bug 453246 Opened 16 years ago Closed 9 years ago

Typing a keyword search where the url is the same as a visited page removes the keyword item and shows the history item as starred when it is not.

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tyghyjbyujvjhb, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080901033305 Minefield/3.1b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080901033305 Minefield/3.1b1pre

Typing a keyword search where the url is the same as a visited (non-starred) page removes the keyword item and shows the history item as starred when it is not.

Reproducible: Always

Steps to Reproduce:
1.Add bookmark http://en.wikipedia.org/wiki/%s with keyword w.
2.Type w Wii in awesomebar, you see the keyword entry as normal.
3.Press enter to add http://en.wikipedia.org/wiki/Wii to history.
4.Type w Wii again.
Actual Results:  
http://en.wikipedia.org/wiki/Wii appears as starred when it is not starred. See screenshot at http://img217.imageshack.us/my.php?image=bugbi0.png.

Expected Results:  
http://en.wikipedia.org/wiki/Wii should appear as a normal history entry, and/or the keyword entry should not have been removed?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080901105930 Minefield/3.1b1pre

This works fine for me (not starred).
Still happens for me in today's nightly, I tested on a clean profile.
Yeah, I can reproduce it now, I possibly misread the problem.
This was probably caused by Bug 392143 or Bug 249468.
The item with a yellow star has always a "W" favicon.
Blocks: 392143
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.