If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add all bookmark keywords to location bar autocomplete drop-down list

VERIFIED FIXED in Firefox 3.1a1

Status

()

Firefox
Address Bar
--
enhancement
VERIFIED FIXED
13 years ago
8 years ago

People

(Reporter: Petey, Assigned: Mardak)

Tracking

(Depends on: 2 bugs)

Trunk
Firefox 3.1a1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -
blocking-aviary1.5 -
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 392143])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
I propose that all bookmark keywords, whether they have yet been used in the
location bar or not, be included in the location bar's autocomplete list.  They
could also have a bookmark icon next to them to indicate they are a bookmark and
not a URL.

The purpose of keywords is to make finding your favorite sites fast and easy. 
As such, my keywords are usually just the first letter of the bookmarks name
(such as "b" for "bugzilla") so that it is, in effect, a hotkey.  However,
complications arise when I have two bookmarks with the same first letter
("bugzilla" and "Blogger" for example) and I risk losing efficiency or
forgetting the keywords because they don't follow the first-letter system.

If bookmark keywords where included in the autocomplete box, I could ditch my
one-letter rhetoric all together and loose negligible efficiency.  I could still
enter "b" and then simply select, with a single keystroke, either "bugzilla" or
"blogger".  Now, wouldn't that be great!?

Comment 1

13 years ago
Adding self to CC and requesting blocking-aviary1.0

It looks like we need a component called something like
@mozilla.org/autocomplete/search;1?name=bookmark-keyword that implements the
nsiautocomplete* interfaces.  We could then add bookmark-keyword to the
autocompletesearch attribute to the url textbox in browser.xul.
Flags: blocking-aviary1.0?

Comment 2

13 years ago
good idea but it is late in the 1.0 development cycle for adding new features,
especially feature without well tested patches.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
*** Bug 282390 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
since we didn't get 1.0 how about 1.1?
Flags: blocking-aviary1.1?
Not something we're going to block for, if a patch comes in soonish we may take it.
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 6

12 years ago
It would be nice to not just have the bookmark keywords in autocompletion but
also every single query that was used with smart keywords.
So we do not just have "g" in autocompletion but also "g foo" and "g bar" etc...

Comment 7

12 years ago
*** Bug 298339 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

12 years ago
*** Bug 278747 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

12 years ago
Suite bug 101642. 

Won't be able to do "g foo" or "g bar" while there's bug 196297.
Depends on: 101642, 196297
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
(Assignee)

Comment 11

10 years ago
Bug 392143 would fix this by showing all keywords as part of the autocomplete list letting the user select which one to use.
Depends on: 392143
(Assignee)

Updated

10 years ago
Assignee: p_ch → edilee
Component: Bookmarks → Location Bar and Autocomplete
QA Contact: bookmarks → location.bar
Whiteboard: [has fix in bug 392143]
Version: unspecified → Trunk
(Assignee)

Comment 12

10 years ago
Created attachment 307997 [details] [diff] [review]
testcase v1

Tests the functionality added by bug 392143 to make sure multiple keywords show up in the autocomplete.
(Assignee)

Comment 13

10 years ago
Created attachment 308272 [details] [diff] [review]
testcase v1.1

Unbitrot from bug 392143.
Attachment #307997 - Attachment is obsolete: true
(Assignee)

Comment 14

10 years ago
Created attachment 315291 [details] [diff] [review]
testcase v1.2

Unbitrot testcase now that it's using the super cool places autocomplete test framework.
Attachment #308272 - Attachment is obsolete: true
(Assignee)

Comment 15

9 years ago
Fixed by bug 392143: http://hg.mozilla.org/mozilla-central/index.cgi/rev/a15164388bf1

http://hg.mozilla.org/mozilla-central/index.cgi/rev/307503c8b6fb
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.