Classic skin fails on Messenger - Mail does not come up

VERIFIED FIXED

Status

P3
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: fenella, Assigned: nbhatla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] ETA: 7/21)

(Reporter)

Description

19 years ago
Mac (2000-07-12-15 M17)
1. On mac, launch the browser and switch it to Classic skin
2. Lre-launch the browser, select Task|Messenger
Actual result: No response. No Messenger pops up
Expect result: should bring up Messenger
3. Exit browser
4. Drag Messenger icon into Netscape icon, 
Actual result: A Messenger window pops up, the 3-pane window are all blank,
eventually Messenger hangs.
Expected result: 3 pane window should display folders, and thread pane and
workable.

Linux (2000-07-12-11 M17)
On Linux, when I use ./netscape -mail option, the Messenger window comes up with
folders,  and headers in thread pane.  However, it freezes. I cannot select
message or view message

This problem does not occur on Win32

Comment 1

19 years ago
mark nsbeta2 since I assume we want folks to use Mail and the classic skin at 
the same time.
Severity: normal → critical
Keywords: nsbeta2
Summary: Classic skin fails on Messenger → Classic skin fails on Messenger - Mail does not come up

Comment 2

19 years ago
side note: Fenella, on Win32, using the classic skin, can you select messages to 
read them?
(Reporter)

Comment 3

19 years ago
Yes.  I can view message on win32 using classic skin
(Reporter)

Comment 4

19 years ago
Hmm! Linux is inconsistent, using the same build, I can view message in Classic
skin.

Comment 5

19 years ago
Putting on [nsbeta2-] radar.  Not critical to beta2.  Adding "relnote" keyword 
for PR2 release. 
Whiteboard: [nsbeta2-]
(Assignee)

Comment 6

19 years ago
Under this morning's build, I was unable to launch Mail as well.  After stepping 
through with the debugger, though, the bug went away.  Now the bug is only 
intermittent even after numerous restarts and without running with the debugger 
beforehand (so Mail mostly launches now).   

After talking with Chris Saari and going over Mozilla with Metrowerks debugger, 
we've concluded that this bug probably relates to a timing issue (bug #44342), 
which was supposedly resolved on 7/11.  However, since some of us are still 
seeing the bug, maybe we should reopen #44342.  

Also, this is a serious bug and should be nominated again for nsbeta2+.  It is 
crucial that the major windows (Browser, Mail, Composer) display under the 
classic skin for this beta release.
Depends on: 44342

Comment 7

19 years ago
clearing status whiteboard per new comments for pdt to reevaluate.
Whiteboard: [nsbeta2-]
(Reporter)

Comment 8

19 years ago
Linux (2000-07-14-08 M17)
RE: comment dated 7/12 on Linux
> On Linux, when I use ./netscape -mail option, the Messenger window comes up
with folders,  and headers in thread pane.  However, it freezes. I cannot select
message or view message

This problem also occurs in the 7/14 Linux builds.
(Reporter)

Comment 9

19 years ago
On linux, sometimes a password dialog pops up. After I enter password and click
ok, seamonkey freezes.

Comment 10

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 11

19 years ago
Nikhil and Andrew, please fix this one soon.
Assignee: hangas → nbhatla

Comment 12

19 years ago
Starting to get familiar with mailnews today... ramping up. Ill help as much as I 
can. Ill powwow with Nikhil.
(Assignee)

Comment 13

19 years ago
Is anyone still seeing this bug from builds after 7/14?  Also, if you are, be 
sure to view bug #44342.  After reading through the bug conversation, it appears 
as if this bug may be a dup of that one.  If anyone is still unable to launch 
Mail in recent builds, then bug #44342 should not be resolved and this should be 
marked as dup.  

Comment 14

19 years ago
duplicate bug http://bugzilla.mozilla.org/show_bug.cgi?id=45725 shows a stack 
trace / infinite loop info from a debug build.

Comment 15

19 years ago
Nikhil: this problem is not the same as 44342 because switching to the modern 
skin fixes the startup problem that is reported.  And, the dup bug reported by 
pinkerton is on the 7/17 builds.
(Assignee)

Comment 16

19 years ago
I don't think bug #45725 is a dup, because it occurs after a succesful launch of 
the mail app, while this bug concerns the inability to successfully launch mail.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA: 7/21
(Assignee)

Comment 17

19 years ago
GOT IT!  I finally tracked this sucker down.  Checkin shortly.

In  /communicator/sidebar/sidebar.css,  the class .iframe-panel will not 
accept a "border-top" style.  With a border-top in addition to the other three 
borders, Mail crashes.  Without a border-top style, it does not!  

I have no idea what's going on here, but this must be a deeper bug.  I will 
temporarily fix it by removing the "border-top" style.  Someone should 
really fix the underlying code though.
(Assignee)

Comment 18

19 years ago
Also, I know believe this bug to be a dup of bug #45725.

Comment 19

19 years ago
Bug 45925 split off for that CSS issue.
(Assignee)

Comment 20

19 years ago
Fix is in.  Be sure to test it in tomorrow's build.  Lemme know if it worked 
across the board.

Comment 21

19 years ago
*** Bug 45725 has been marked as a duplicate of this bug. ***

Comment 22

19 years ago
marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 23

19 years ago
Updating QA contact.  Fenella, fix may not show up until 7/21 builds.
QA Contact: paw → fenella
(Reporter)

Comment 24

19 years ago
You are right, Jan, the fix is not in today's build, I'll check tomorrow's.
Thanks,

Comment 25

19 years ago
Reopening. Actually, the fix (comment out border-top:) went in for Mac, and I 
mail works with the classic skin on the Mac. However, Linux also needed some 
of this love, and on a current tip build, I hang using mailnews with the classic 
skin [and I get that same recursive stack of box reflows].

If I comment out 'border-top:' for .iframe-panel in 'sidebar.css' for the 
classic skin on Linux, I don't get the hang, and mailnews runs. Just need to 
make that checkin to the Linux skin to get past this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 26

19 years ago
Sorry about that.  I'll check the fix in today for linux as well.
(Assignee)

Comment 27

19 years ago
Linux fix is checked in.  Marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 28

19 years ago
Unable to verify due to bug46035
(Reporter)

Comment 29

19 years ago
Linux (2000-07-26-08 M17)
Win32 (2000-07-26-09 M17)
mac (2000-07-25-11 M17)
Verify that this problem has been fixed.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.