Exception "Can't use cf_anyCustomField as a field name" when trying to execute a saved search from bugzilla 3.0

RESOLVED DUPLICATE of bug 373869

Status

()

Bugzilla
Query/Bug List
--
critical
RESOLVED DUPLICATE of bug 373869
10 years ago
10 years ago

People

(Reporter: Andreas Bühler, Unassigned)

Tracking

x86
Windows Vista

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322; InfoPath.2)
Build Identifier: 3.2rc1

We're getting the following exception when we have a saved search which includes one of our custom fields:

URL: https://issues.heiler.com/buglist.cgi?cmdtype=runnamed&namedcmd=NORDLB
Can't use cf_SupportID as a field name. 

This only happens for previously saved searched, if we create a new one everything is fine.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Blocks: 452731
Version: unspecified → 3.2

Comment 1

10 years ago
Looks like you installed a development version of Bugzilla (either 2.23.x or 3.0rc1). All custom field names must be lowercase now.
No longer blocks: 452731
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373869
(Reporter)

Comment 2

10 years ago
Yes we used 3.0rc1, but shouldnt the update also actualize the saved searches, not only the column names in the database?
Is there any way to update saved searches in an easier way (directly in database?) or do we have to edit all saved searches again?
You need to log in before you can comment on or make changes to this bug.