Last Comment Bug 453517 - Fennec support on AMO
: Fennec support on AMO
Status: VERIFIED FIXED
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Administration (show other bugs)
: unspecified
: All All
: -- normal
: 4.0.3
Assigned To: Michael Morgan [:morgamic]
:
:
Mentors:
http://starkravingfinkle.org/blog/200...
Depends on:
Blocks: 465338
  Show dependency treegraph
 
Reported: 2008-09-03 13:43 PDT by Cesar Oliveira [:cesar]
Modified: 2016-03-07 07:30 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
logo 110x105 (15.20 KB, image/png)
2008-09-09 19:42 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details
logo 110x105 (16.15 KB, image/png)
2008-09-09 21:08 PDT, Stuart Parmenter
no flags Details
logo 34x34 (4.77 KB, image/png)
2008-09-09 21:08 PDT, Stuart Parmenter
no flags Details
v1, constant changes (1.72 KB, patch)
2008-10-21 11:46 PDT, Michael Morgan [:morgamic]
wclouser: review+
laura: review+
Details | Diff | Splinter Review
stub .xpi for test scenario (5.12 KB, application/x-xpinstall)
2008-10-27 22:07 PDT, Michael Morgan [:morgamic]
no flags Details
v2, adds app support but hides menu until we figure out details (4.89 KB, patch)
2008-10-28 17:58 PDT, Michael Morgan [:morgamic]
wclouser: review+
Details | Diff | Splinter Review
sample xml file to throw into EM (1.32 KB, text/xml)
2008-10-28 19:18 PDT, Michael Morgan [:morgamic]
no flags Details
victory! (158.16 KB, image/png)
2008-10-31 00:29 PDT, Michael Morgan [:morgamic]
no flags Details

Description Cesar Oliveira [:cesar] 2008-09-03 13:43:03 PDT
Mark Finkle made a post (linked) that shows support for the addons manager in M7. We should update our appversions to allow Fennec addons :

https://addons.mozilla.org/en-US/firefox/pages/appversions
Comment 1 Michael Morgan [:morgamic] 2008-09-03 15:47:20 PDT
Could we either make this a tracking bug or break this into more specific pieces (or both)?
Comment 2 Justin Scott [:fligtar] 2008-09-04 12:29:56 PDT
This can be the tracking bug. Assigning to Basil since he's working with the Fennec folks on this:

https://wiki.mozilla.org/Fennec:Addons
Comment 3 Basil Hashem [:baz] 2008-09-09 10:17:59 PDT
Per today's discussion, we need the following which we will add to the preview instance of AMO (http://preview.addons.mozilla.org):
- Fennec App ID: {a23983c0-fd0e-11dc-95ff-0800200c9a66}
- Fennec minVersions: {please list all of them, e.g. 0.7a1, etc...}
- Fennec maxVersion: {please list all of them, 0.7.*, etc}
- Category names for Fennec
- A Fennec icons (110px × 105px for the upper left image) - (see https://addons.mozilla.org/en-US/sunbird/ for example)
Comment 4 Stuart Parmenter 2008-09-09 19:21:14 PDT
- Fennec App ID: {a23983c0-fd0e-11dc-95ff-0800200c9a66}

- Fennec minVersions: 0.7
0.7 was the first version that supported addons, so this should be OK.

- Fennec maxVersion: 1.0a1
(I guess we should figure out what we're going to call alpha 1.  1.0a1 or 0.8... Let me get back to you on this.)

- Category names for Fennec
"Experimental" might be a good category for now -- I suspect as we move forward we might want a list more like the Firefox one.


icon coming up...
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2008-09-09 19:42:39 PDT
Created attachment 337802 [details]
logo 110x105
Comment 6 Stuart Parmenter 2008-09-09 21:08:24 PDT
Created attachment 337811 [details]
logo 110x105

not sure why this version has different ears than brad's, but here we go..
Comment 7 Stuart Parmenter 2008-09-09 21:08:42 PDT
Created attachment 337812 [details]
logo 34x34
Comment 8 Michael Morgan [:morgamic] 2008-10-21 11:46:15 PDT
Created attachment 344143 [details] [diff] [review]
v1, constant changes

This is the code to support fennec on AMO, need the SQL which will come in a bit.  Problem I have right now is that even with stubs uploaded they aren't coming through in the API search.
Comment 9 Michael Morgan [:morgamic] 2008-10-27 22:06:46 PDT
Aside from the patch, here are the steps needed to fully test:

* Add Fennec to AMO database via Application manager
** GUID: {a23983c0-fd0e-11dc-95ff-0800200c9a66}
** Supported: Yes (checked)
* Add two versions of Fennec via Application manager
** 0.1 
** 1.0.*
* Add Fennec categories
** Fennec
** Extension
** en-US
** Mobile Tools
** Mobile Tools
* Upload test XPI 
** Use xpi for read-it provided
** Choose "Mobile Tools" category
** Add descriptions and summary -- "Reads the text on a webpage"
** Complete add-on -- this moves it into the sandbox
* AMO Admin - make add-on public
** Open add-on manager
** Type "read it" 
** Choose the add-on (should be a high addon_id)
** Set add-on status to public
** Set file status to public
** Set highest status to public
* NOTE: Make sure to run bin/update-search-views.php in order to update fulltext indexes for the newly added add-on
* Test the API 
** Single add-on page: /en-US/fennec/api/addon/9237/
** Search: /en-US/fennec/api/1.1/search/read+it/all/10/Darwin/0.5
Comment 10 Michael Morgan [:morgamic] 2008-10-27 22:07:22 PDT
Created attachment 345050 [details]
stub .xpi for test scenario
Comment 11 Michael Morgan [:morgamic] 2008-10-27 22:08:26 PDT
Finkle, if you'd like to test a build and have VPN to MPT, you could try this:
http://morgamic.khan.mozilla.org/amo/site/en-US/fennec/api/1.1/search/read/all/10/ALL/0.1

IP/Host info if it doesn't respond:
10.2.74.111 morgamic.khan.mozilla.org
Comment 12 Michael Morgan [:morgamic] 2008-10-27 22:09:19 PDT
Laura -- could you review the patch above?  The API error I was experiencing was caused by not running update-search-views.php -- after I ran it, results showed up properly.
Comment 13 Michael Morgan [:morgamic] 2008-10-28 16:16:00 PDT
Comment on attachment 344143 [details] [diff] [review]
v1, constant changes

Wil, could you take a look at this config patch?  The app_id will have to be changed, but I will update the patch once it's updated in preview/prod.
Comment 14 Wil Clouser [:clouserw] 2008-10-28 16:48:13 PDT
Comment on attachment 344143 [details] [diff] [review]
v1, constant changes

You'll need to define and merge out main_prettyname_fennec as well.
Comment 15 Michael Morgan [:morgamic] 2008-10-28 17:58:25 PDT
Created attachment 345213 [details] [diff] [review]
v2, adds app support but hides menu until we figure out details

Older patch plus some logic to exclude from the sprited other-apps (app-chooser) menu.  I don't think we're ready to add install buttons and have a public fennec add-ons site yet, but these changes will unblock the API.
Comment 16 Michael Morgan [:morgamic] 2008-10-28 18:39:25 PDT
Comment on attachment 345213 [details] [diff] [review]
v2, adds app support but hides menu until we figure out details

(I've spotted/fixed the fennech1 CSS error)
Comment 17 Michael Morgan [:morgamic] 2008-10-28 19:18:55 PDT
Created attachment 345226 [details]
sample xml file to throw into EM
Comment 18 Michael Morgan [:morgamic] 2008-10-29 18:46:15 PDT
r19408, pushing Thursday.
Comment 20 Michael Morgan [:morgamic] 2008-10-31 00:29:38 PDT
Created attachment 345675 [details]
victory!

Mark -- I created the "Experimental" category as requested so just edit the add-on and add it to that category and it should work.  You can also edit a version/file to add Fennec support just as with Firefox.

Note You need to log in before you can comment on or make changes to this bug.