Closed Bug 45432 Opened 20 years ago Closed 19 years ago

Leaking PRLibrary if a library won't load

Categories

(NSPR :: NSPR, defect, P3)

PowerPC
All
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: beard, Assigned: wtc)

References

()

Details

Attachments

(1 file)

See the blame URL above. If the library fails to load on line 929, the PRLibrary 
object is leaked. This is rare, but I'm seeing it in Mozilla builds when 
libraries fail to load during auto registration.
I'm going to attach a patch that fixes this memory leak
and a similar leak.  Please review and test it.  (I'm
not set up to build on Mac right now.)  Thanks.
Status: NEW → ASSIGNED
Attached patch Proposed patch.Splinter Review
Target Milestone: --- → 4.1
*** Bug 44613 has been marked as a duplicate of this bug. ***
I checked in the fix on the main trunk.

/cvsroot/mozilla/nsprpub/pr/src/linking/prlink.c, revision 3.43
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This isn't checked into the branch that Mozilla uses, so the leak is still 

present in Mozilla.

Status: RESOLVED → REOPENED
OS: All
Resolution: FIXED → ---
I merged the fix on the NSPRPUB_CLIENT_BRANCH.
/cvsroot/mozilla/nsprpub/pr/src/linking/prlink.c, revision 3.34.2.8.
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → FIXED
Duplicate of this bug: 638172
You need to log in before you can comment on or make changes to this bug.