url not loaded at first press of enter key

VERIFIED FIXED in M5

Status

SeaMonkey
UI Design
P1
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: cpratt, Assigned: Radha on family leave (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Launch apprunner. (I used the 5 April build.) Type a URI into the Location:
control. Press Enter. Result: nothing happens. You have to press the Enter key a
second time for apprunner to start loading the URI.

Updated

20 years ago
Assignee: don → radha
Component: Apprunner → XPApps
OS: Windows NT → All
Priority: P3 → P1
Hardware: PC → All
Target Milestone: M4

Comment 1

20 years ago
Re-assigned to radha@netscape.com, set target milestone to M4, changed priority
to P1, changed platform and OS to All.

Comment 2

20 years ago
*** Bug 4555 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Summary: URI not loaded at first press of Enter key → URL not loaded at first press of Enter key
Status: NEW → ASSIGNED
CC ing pavlov. Pavlov, Do you have any info on what happens here atleast for
linux

Comment 4

20 years ago
*** Bug 4652 has been marked as a duplicate of this bug. ***

Updated

20 years ago
QA Contact: 3853 → 3849

Comment 5

20 years ago
*** Bug 4714 has been marked as a duplicate of this bug. ***
Fix checked in last night.  In navigator.xul, rdfCore.add() failed and thereby
not executing the loadURL call which was after that. This rdfCore.add() was
totally unnecessary, so commented it out.
(Reporter)

Comment 7

20 years ago
I don't see a fix in this morning's build on Windows 98 (the 8/9 am April 8
builds). Mac works okay. Linux works okay. Beth, could you please double-check
this under Windows?
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
cyeh verified this last night for me in windows and it did work then. Marking
fixed.

Updated

20 years ago
Status: RESOLVED → REOPENED
Summary: URL not loaded at first press of Enter key → URL not loaded at first press of Enter key (first time)
Target Milestone: M4 → M5

Comment 9

20 years ago
The very first time you enter a URL on Windows, you still have to hit enter
twice. However, on subsequent attempts you only have to hit it once. Re-opening
bug, changing Summary, and changing Target Milestone since it's probably not an
M4 stopper anymore.
Tested on 1999040818 builds on win95.
(Reporter)

Updated

20 years ago
Resolution: FIXED → ---

Comment 10

20 years ago
*** Bug 4893 has been marked as a duplicate of this bug. ***

Comment 11

20 years ago
Still a problem on Mac, too (4.9.99 AM build)
My checkin got removed by Matt's checkin later. I refixed this again today.
Please verify in all platforms. Thanks.

Comment 13

20 years ago
Still an issue with 4-10-99 nightly build for Win32 (WinNT).

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 14

20 years ago
VERIFIED fixed for:
MacOS 1999041112
Linux 1999041108
WinNT 1999041010
(Reporter)

Updated

20 years ago
Status: VERIFIED → REOPENED
(Reporter)

Updated

20 years ago
Resolution: FIXED → ---
(Reporter)

Comment 15

20 years ago
This isn't working for me on (at least) the april 13 linux build.
(Reporter)

Comment 16

20 years ago
*** Bug 4893 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

20 years ago
Summary: URL not loaded at first press of Enter key (first time) → url not loaded at first press of enter key
Target Milestone: M5 → M4
(Reporter)

Comment 17

20 years ago
I should also note that (according to paulmac) this has not been fixed in m4
builds, although it is apparently working in early m5 builds. this should be
fixed for the m4 release, I believe.

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 18

20 years ago
I'm going to mark it fixed so it gets re-tested with
the Tuesday afternoon 4/13 m4 branch builds.
I think some reports of not working are on M5 builds where
the changes have not yet been propogated forward.

If radha or anyone find we are still broken on the next m5 candidates
please reopen
I pulled the M4 branch  today and I see my changes there. Please verify once
again that it is fixed in all platforms in M4 as well as in M5 builds.
Thanks,
(Reporter)

Comment 20

20 years ago
it's fixed in the win32 build (nt 4). beth, i'll check linux and mac os tomorrow
unless you get to it first. thanks!

Updated

20 years ago
Target Milestone: M4 → M5

Comment 21

20 years ago
the fix is reflected in the Linux M4 (1999041316) build...more later

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 22

20 years ago
marking VERIFIED for M4(19990413) and current 1999041508 builds on all platforms.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.