Closed Bug 454473 Opened 12 years ago Closed 11 years ago

Bookmarks Toolbar repopulates after restore from minimize (unnecessary tab bar stretch side effect)

Categories

(Core :: Widget: Win32, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: Noah, Assigned: vlad)

References

Details

(Keywords: fixed1.9.1, polish, regression)

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080907032646 Firefox/3.0
Build Identifier: 

Opening any firefox window from a minimized state results in the bookmarks toolbar being empty for half a second, then populates. Also, while having two or more tabs open, both the tab scroll arrows appear within that half second, causing the tabs to shift or jolt unnecessarily.

Steve England aka chob did what he does best and got us a regression range [thanks again!]:
Between firefox-3.1a2pre.en-US.win32 14-Aug-2008 0512 & firefox-3.1a2pre.en-US.win32 15-Aug-2008 0746

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2008-08-14-04-mozilla-central/ & http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2008-08-15-06-mozilla-central/

Screenshots and screencast attached

Reproducible: Always
Attached image Screenshot 1
Attached image Screenshot 2
Attachment #337751 - Attachment description: Screencast → Screencast normal behavior
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, regression
1. Have bookmarks on your bookmark toolbar
2. Minimize Firefox to the taskbar
3. Restore Firefox

Expected:
- Firefox restores and bookmarks toolbar is populated immediately

Actual:
- Firefox restores and the bookmarks toolbar is populated after about half a second which looks sloppy.
Flags: blocking1.9.1?
Duplicate of this bug: 455136
Comment from duped bug 455136:
"
This regressed when bug 448132 got fixed.
Basically, I think this has the identical cause as bug 452794.
Iirc, there are resize event handlers in the toolkit code that do stuff (like
adjusting the bookmarks toolbar items for example) to make the ui look correct
for that particular size.

I can see the bookmarks toolbar reflowing on unminimizing (I have the bookmarks
toolbar completely filled with items) and I can see the "X" button on the tabs
reappear again, which indicates they were gone when the window got minimized.
"
Assignee: jag → nobody
Blocks: 448132
Component: XUL → Widget: Win32
QA Contact: xptoolkit.widgets → win32
I think this is also the cause of the GMail collapsing thing, when unminimizing. I think the patch for bug 448132 needs to be backed out.
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P2
Assignee: nobody → vladimir
Just confirming the bug in Firefox 3.1 Beta 1. And as Martijn pointed out, there is some reflow after restoring from the minimized state for Gmail and also in Google Reader for me. See screenshots.
This seems to fix this and doesn't regress acid3 -- only the toplevel HWND returns TRUE for IsIconic, but the problem arises because child windows are the ones that go to 0x0 (toplevel windows end up going to whatever the iconic size is).
Attachment #346336 - Flags: superreview?(dbaron)
Attachment #346336 - Flags: review?(tellrob)
Attachment #346336 - Flags: superreview?(dbaron) → superreview+
Comment on attachment 346336 [details] [diff] [review]
check toplevel window for iconic, not whatever the child might be

The easiest way to test the relevant bit of acid3 right now is probably layout/style/tests/test_acid3_test46.html , for what it's worth.
Attachment #346336 - Flags: review?(tellrob) → review+
checked in.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Blocks: 452794
You need to log in before you can comment on or make changes to this bug.