Closed Bug 454779 Opened 11 years ago Closed 11 years ago

Default dom.disable_window_move_resize to true

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ted, Assigned: ted)

References

()

Details

Attachments

(1 file)

We should flip this pref to true by default. Does anyone want webpages to resize their browser window, in this day and age of tabbed browsing? I would say we could do something smart about only letting it affect popup windows, but sites can just size popups correctly in the window.open call, and people can resize the window if they need to. Let's just bury this web nuisance for good.

(And yes, there are still sites that do this, for example: http://www.themeadowsbp.com/ )
Attached patch flip the prefSplinter Review
Here's a patch.
Assignee: nobody → ted.mielczarek
Status: NEW → ASSIGNED
Attachment #338114 - Flags: review?(mconnor)
That's a lot of history. One thing I failed to see in any of those bugs was links to actual sites that we broke with this behavior. Can anyone source that?
Ah ok, there was one site linked from bug 309251 (mentioned in a dupe) that was broken, but that site no longer seems to exist. I'm not sure why this actually got flipped back. It doesn't look like we got a lot of feedback saying things were broken, just one bug filed about a broken site, and a couple of web authors complaining that resizeTo didn't work.
According to my vague memories of 2005, two reasons: generally, the realization that it was a sledgehammer when what we actually wanted was the ball-peen of bug 144069 (or bug 186708, or both), and more pressingly the realization that it would break a longtime usage of resizeTo with no idea how widely used it still was, when we were in a short release cycle (it was released in 1.5b1 in early September, we did one more beta in October and released in November) when we still didn't have all that much leverage to move the web.

So if I was going to argue for flipping it back, I'd want to claim that either we want this instead of bug 144069, or that nobody will ever bother fixing that, and that we are early enough in a cycle with wide enough beta usage that we can either find out that we'll still break too many sites and flip it back if needed, or that we now have enough leverage to say that every site which uses resizeTo must be rewritten.
I think we should:

* Never allow sites to resize windows that are owned by the user (bug 144069, bug 186708).  (This is always malicious and/or annoying.)

* Always allow sites to resize pop-up windows at times when they are allowed to both close the pop-up window and open a new one.  (Disallowing it is pointless in this case!)

Since resizing pop-ups would be allowed in response to clicks, legitimate uses would not be broken.  For example:

* You click a thumbnail and get a "full-size image" pop-up.  You click another thumbnail and the pop-up is reused for another image, which might be a different size.

* http://www.myfreecams.com/ (NSFW) resizes "private message" pop-ups when you click the "show video" link.

The only widespread brokenness would be from sites that open image/video pop-ups before they know what size they should be, and then resize the windows onload.  I'm fine with breaking that, since:

(1) Forcing those sites to determine window sizes ahead of time would improve the sites for users of all browsers.

(2) Such behavior is difficult to distinguish from malicious or unwanted behavior.

(3) The brokenness isn't too bad, since users can resize the windows themselves thanks to the fix for bug 177838.

(4) Users can work around the brokenness by adding sites to the pop-up blocker whitelist (if not a more specific whitelist, see bug 412862).

(5) If we keep the pref, users can work around the brokenness by flipping the pref, without having to worry about letting malicious sites resize non-pop-up windows.
(In reply to comment #6)
> I think we should:
> 
> * Never allow sites to resize windows that are owned by the user (bug 144069,
> bug 186708).  (This is always malicious and/or annoying.)

While I agree with this, I feel like we're holding out for the perfect solution. Those bugs have been open for a long time and I don't see any progress being made in them. Since bug 177838 was fixed, sites that are broken by this aren't terribly broken, because users can manually resize the window. I think just flipping this pref will make users less likely to be annoyed by having their main browser window resized, and force some people to manually resize popup windows that no longer can auto-resize themselves. All that for essentially no effort.
Duplicate of this bug: 452019
Attachment #338114 - Flags: review?(mconnor) → review-
Comment on attachment 338114 [details] [diff] [review]
flip the pref

I don't think the benefits outweigh the negative aspects of doing this by default, and I think the number of times it'd be more annoying will outnumber the number of times this is annoying now.
What are the negative aspects? What would be annoying about it? You can resize all windows by default nowadays.
Not going to keep this open if mconnor doesn't want the patch.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
I split out my proposal in comment 6: it is now bug 502561.
You need to log in before you can comment on or make changes to this bug.