bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

No vertical space between label and underline indicating accesskey in Shredder main menu

VERIFIED FIXED in Thunderbird 3.0b2

Status

Thunderbird
General
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: wladow, Assigned: wladow)

Tracking

({polish, regression})

Trunk
Thunderbird 3.0b2
x86
Windows Vista
polish, regression
Bug Flags:
blocking-thunderbird3 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Created attachment 338288 [details]
screenshot - Win Vista

Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1b1pre) Gecko/20080911030724 Shredder/3.0b1pre

Shredder's main menu items have broken accesskey position, see the screenshot. Context menus don't suffer from it. 

I think bug 433109 can be the regression candidate here.
Flags: blocking-thunderbird3?
Target Milestone: --- → Thunderbird 3.0b1
(In reply to comment #0)
> I think bug 433109 can be the regression candidate here.

I've seen this issue since before that was checked in, so no.
I believe you meant horizontal instead of vertical. As what I can see this exists not only for Thunderbird. Even Firefox is affected and possibly any other application based on XUL runner. It's not a regression from bug 433109 because it can be seen years back. No idea if this has ever been worked.

Enn, is it a known issue for you and we probably have already a bug describing this issue?
No longer blocks: 433109
Component: General → XP Toolkit/Widgets: Menus
Flags: blocking-thunderbird3?
Keywords: regression
OS: Windows Vista → All
Product: Thunderbird → Core
QA Contact: general → xptoolkit.menus
Hardware: PC → All
Summary: No vertical space between label and accesskey in Shredder main menu → No horizontal space between label and accesskey in Shredder main menu
Target Milestone: Thunderbird 3.0b1 → ---
Created attachment 339340 [details]
Overlapping in Minefield

Same effect using latest Minefield. Also happens on OS X for longer menu entries.

Comment 4

10 years ago
You haven't described what you think is a bug.
(Assignee)

Comment 5

10 years ago
Could you tell me what are you talking about? Pls, look carefully at my screenshot again and see *vertical* position of accesskeys. They need to be positioned one pixel lower, because there's no space vertical between them and labels. Your screenshot does not show this issue and I don't see it using any other trunk app. Vertical means "up-down" ;) And it's definetely a regression.
Severity: normal → critical
Component: XP Toolkit/Widgets: Menus → General
Keywords: regression
Product: Core → Thunderbird
QA Contact: xptoolkit.menus → general
Target Milestone: --- → Thunderbird 3.0b1
(Assignee)

Updated

10 years ago
Flags: blocking-thunderbird3.0b1?
(Assignee)

Updated

10 years ago
Summary: No horizontal space between label and accesskey in Shredder main menu → No vertical space between label and accesskey in Shredder main menu
(Assignee)

Updated

10 years ago
OS: All → Windows Vista
Hardware: All → PC

Comment 6

10 years ago
OK, I see that issue in the screenshot. If this was a recent regression, it may be from bug 433109.
(Assignee)

Comment 7

10 years ago
Henrik: now I see what you are talking about - keyboard shortcuts/command keys. But that's not what this is about, really. Note that accesskeys and keyboard shortcuts are pretty different things.
(Assignee)

Comment 8

10 years ago
(In reply to comment #6)
> OK, I see that issue in the screenshot. If this was a recent regression, it may
> be from bug 433109.

Per Comment #1 no.
Sorry for the confusion. Now I'm up-to-date. Thanks Vlado. It would be great if you could have a look at different nightly builds and try to isolate when the seen effect starts to happen. Then it will be easier to check which patch on another bug is responsible for.
Keywords: regressionwindow-wanted
Regressionwindow: 2008072303 - 2008072500

it's a cvs -> mercurial switch, 2008072303 is the last available cvs trunk build, 2008072500 is the first available comm-central build
Keywords: regressionwindow-wanted
Whiteboard: [regressionwindow comment #10]
Check-ins in this time frame:

Bonsai: http://tinyurl.com/4xl75c
Hg:     http://tinyurl.com/48nfeh

I believe we have to focus the bonsai checkins. Mark, do you have an idea?
Attachment #339340 - Attachment is obsolete: true
(In reply to comment #11)
> Check-ins in this time frame:
> 
> Bonsai: http://tinyurl.com/4xl75c
> Hg:     http://tinyurl.com/48nfeh
> 
> I believe we have to focus the bonsai checkins. Mark, do you have an idea?

No, I think that because this spans the cvs -> hg switch over, then you can say that the regression range in hg would be anything from when FF moved 1.9.1 into hg and when we switched.
Mmh, so which part within the source is responsible for drawing the underlines of the accesskeys?
We're not using the blocking-thunderbird3.0b1? flags now, we're using a combination of 3 and the target milestone.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3?

Updated

10 years ago
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0b2

Comment 15

10 years ago
Could someone educate me what is sev=critical?  I'm missing something.

Updated

10 years ago
Severity: critical → normal
comm-central calendar 1.0pre builds suffer from this too.

Comment 17

10 years ago
moving to b2
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0b2

Comment 18

10 years ago
Created attachment 351941 [details]
space missing - shredder 20081208 / linux

I'm not sure it's the same bug - although it sure looks the same.
I've started seeing this on linux. Firefox nightlies does *not* have this problem.

Have regressed on linux sometime during the last two months.
As a hack, setting either the margin-top or the margin-bottom of the label in DOMi to 1px (instead of 0px) resolves the issue.

Minefield still has 0px though.

(In reply to comment #18)
> 
> I'm not sure it's the same bug - although it sure looks the same.
> I've started seeing this on linux. Firefox nightlies does *not* have this
> problem.
> 
> Have regressed on linux sometime during the last two months.

I don't see this issue on 20081203 (custom build).
Tweaking title to make it easier for people new to the bug.  Denying blocking because while ugly, I don't think we'd delay shipping just for this.  Patches welcome!
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Summary: No vertical space between label and accesskey in Shredder main menu → No vertical space between label and underline indicating accesskey in Shredder main menu
Could we have at least a wanted3.0 flag? This is highly visible and I suspect a lot of bug reports will be filed on that - even with a better summary.
Flags: wanted-thunderbird3?
Created attachment 358159 [details] [diff] [review]
fix menubar, v1
[Checkin: Comment 27]

This is how Firefox solves the issue. As Firefox uses 2 separate themes for XP and Vista, they have placed #menubar-items hack into /aero, but this seems to work fine on Vista with no negative effect on XP.
Assignee: nobody → wladow
Status: NEW → ASSIGNED
Attachment #358159 - Flags: review?(bugzilla)
(In reply to comment #22)
> Created an attachment (id=358159) [details]
> fix menubar, v1

+/* the default settings for the throbber hbox is too tall for vista menus */
+#navigator-throbber > hbox {
+  border-top: 0px;
+  border-bottom: 0px;
+  padding-bottom: 1px;
+  -moz-margin-end: 1px;
+} 
 
Where is this actually used? I was expecting the "check for updates" menu item in the help menu, but I can't see it there or on any other menus.
Flags: wanted-thunderbird3? → wanted-thunderbird3+
No, it's an application throbber in the menubar, the throbber is making our menubar taller without this applied. This is copied from bug 355789.

Comment 25

10 years ago
(In reply to comment #19)
> I don't see this issue on 20081203 (custom build).

I don't either on my own builds. Just on official nightlies...
Comment on attachment 358159 [details] [diff] [review]
fix menubar, v1
[Checkin: Comment 27]

Sorry for the delay in getting back to this.

I've now located where we display the throbber so this patch looks fine, lets get it out for some testing.

r=me.
Attachment #358159 - Flags: review?(bugzilla) → review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed, polish
Whiteboard: [regressionwindow comment #10]
Comment on attachment 358159 [details] [diff] [review]
fix menubar, v1
[Checkin: Comment 27]


http://hg.mozilla.org/comm-central/rev/deb38df929ee
Attachment #358159 - Attachment description: fix menubar, v1 → fix menubar, v1 [Checkin: Comment 27]
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090203 Shredder/3.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.