Message that Inbox is full while being almost empty

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Alain Fluet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.16 (20080708)

I only have four messages left in my inbox and I get a message that my inbox is full, to remove older messages. I have no problem downloading messages from IE and no incoming message is large or has attached files to would create a problem (in fact, no attached files at all on the last two downloads). I don't see anything in the configuration that might limit the incoming messages. This started yesterday only and I've been using Thunderbird for years now.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Did you ever used file/compact folders or right click on the inbox and selected compact folder ?
(Reporter)

Comment 2

10 years ago
No, I haven't used these functions as I never had any messages to require their use. I solve the problem by erasing the account and recreating it. It did solve my problem, but I'd like to know a better way than this drastic avenue!
When you delete a message in the Thunderbird/Seamonkey UI the message isn't deleted in the file because that would result in a complete rewrite of the full file.
Example: You have a inbox folder with 1gb mails and you delete one mail in it. 
This would take minutes because you would have to rewrite the full file.

Thunderbird changes only one byte in the message file. This byte indicates that the message is deleted and Thunderbird doesn't show it in the UI. Changing one byte in the middle of a 1GB file is fast and doesn't need a rewrite of the complete file. That means that the golder file will grow until you do something that every database contains: You start a purge, vacuum (sqlite), defragmentaion (for filesystems which are like a database) and in the case of Thunderbird a compact folder.

Using compact folder starts a rewrite of the file without the "marked as deleted" messages.

Why do you got the "Mailbox is full" error ?
You hit the 4GB/2GB filesize limit of a folder.

This will hopefully get better in the future if they implement this purging of the database automatically
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

10 years ago
Thanks Matthias for your explanation. I wasn't aware of that. I thought a deleted message was completely deleted. I'll use the compacted function in the future. Thanks again!
Resolution: INCOMPLETE → FIXED
Resolution: FIXED → INVALID

Comment 5

10 years ago
I can not down any mail because of the error message about the folder being full and delete and compress messages

Comment 6

10 years ago
I have another computer that I am able to download mail on using Thunderbird.  I am using a Emachine that I have had for over a year and have uninstalled and reinstalled the latest version of Tbird
reinstalling Thunderbird shouldn't help because all the user data loives in your profile and the profile isn't deleted with a reinstall.

Compacting/compressing folders doesn't help ?

Comment 8

10 years ago
Thanks Matthias but compressing the folder does not work either.  I have been using Thunderbird for several years and I have never had this error message before.  Like I said, I have a second computer that also has Tbird installed and I have no problem receiving mail and I have many more messages in the folder.  I think there is something wrong with my main computer an Emachines w/ Vista.  I have not made any changes to the config or anything.  This just started happening in the past week
Can you please create a new bug, add me to the CC list because we shouldn't SPAM Alan with this ?

Comment 10

8 years ago
resetting to incomplete
Resolution: INVALID → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.