Closed Bug 456090 Opened 14 years ago Closed 14 years ago

New translations can't be saved

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fligtar, Assigned: wenzel)

References

Details

When changing an add-on's description or any other text field and saving, the success page shows the field updated, but going back to the page will look like it wasn't actually saved because it's cached.
Sounds like a good excuse to use the new object caching framework.
Actually this has nothing to do with caching. It starts a transaction, saves the data properly, and then rolls back. No idea why - it doesn't happen on dev copy but happens on preview and production.
I was using the 3.5 branch to test this locally and it worked fine there, but doesn't on trunk. So, something changed on trunk recently that made new translation strings rollback. This isn't exclusive to the new Dev CP tool, this also broke the old tool which didn't have any changes in this area.

I haven't been following AMO development as closely - does someone know what might have caused this?
Severity: normal → critical
Summary: Add-on changes being cached in Dev CP → New translations can't be saved
I cannot confirm this on my dev copy but I can sure imagine where it comes from: A change to the aftersave callback of the addon model led to the app_model's aftersave callback not being executed anymore. The latter is responsible for calling commit() on the transaction.
I added the missing parent:: call in r18412. Apologies.

Fligtar, can you confirm that this was the problem? As I said, I was unable to reproduce the problem in the first place on my local dev copy. I'll make sure to confirm it on preview though once it lands.
Keywords: push-needed
I can't reproduce the bug on preview, even though my fix hasn't landed there yet: Name changes to an arbitrary add-on take effect immediately.
Thanks Fred. This fixed it on my dev copy and preview hasn't caught up yet.

morgamic: can we tag and push this ASAP? People are currently editing their add-ons and not realizing their changes aren't sticking. And new add-ons that have been submitted are basically pointless.
Assignee: nobody → fwenzel
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Blocks: 456205
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.