Closed Bug 456235 Opened 12 years ago Closed 12 years ago

Fix thresholds for EM-related mlk increase (68 bytes) after ChatZilla bug 420589 checkin

Categories

(SeaMonkey :: Build Config, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0a1

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: memory-leak)

It seems the thresholds should be updated (downward),
especially on MacOSX which didn't catch this new mlk at all.

*****

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221948004.1221952097.28994.gz&fulltext=1
Linux comm-central dep unit test on 2008/09/20 15:00:04
TEST-PASS | runtests-leaks | WARNING leaked 143048 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8500 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8620 bytes during test execution

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221951809.1221955874.6320.gz&fulltext=1
Linux comm-central dep unit test on 2008/09/20 16:03:29
TEST-PASS | runtests-leaks | WARNING leaked 143116 bytes during test execution
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 8568 bytes during test execution (should have leaked no more than 8520 bytes)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 8688 bytes during test execution (should have leaked no more than 8620 bytes)

***

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221949090.1221953765.1140.gz&fulltext=1
MacOSX 10.4 comm-central dep unit test on 2008/09/20 15:18:10
TEST-PASS | runtests-leaks | WARNING leaked 21360 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8512 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8632 bytes during test execution

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221953479.1221958167.12484.gz&fulltext=1
MacOSX 10.4 comm-central dep unit test on 2008/09/20 16:31:19
TEST-PASS | runtests-leaks | WARNING leaked 21428 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8580 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8700 bytes during test execution

***

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221947579.1221951210.26755.gz&fulltext=1
Win2k3 comm-central dep unit test on 2008/09/20 14:52:59
TEST-PASS | runtests-leaks | WARNING leaked 21425 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8457 bytes during test execution
TEST-PASS | runtests-leaks | WARNING leaked 8577 bytes during test execution

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221951602.1221955310.4835.gz&fulltext=1
Win2k3 comm-central dep unit test on 2008/09/20 16:00:02
TEST-PASS | runtests-leaks | WARNING leaked 21493 bytes during test execution
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 8525 bytes during test execution (should have leaked no more than 8477 bytes)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 8645 bytes during test execution (should have leaked no more than 8577 bytes)
If bug 447604 caused a new leak, shouldn't it get backed out?
(In reply to comment #1)
> If bug 447604 caused a new leak, shouldn't it get backed out?

I did it ... before filing this report ;->
Summary: New (small) mlk after bug 447604 checkin ... Need to adjust thresholds → New (68 bytes) mlk after bug 447604 checkin ... Need to adjust thresholds
The culprit is not bug 447604 ... which was the only Hg checkin between the quoted builds.

Second guess are the only other (cvs, ChatZilla) checkins:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-09-20+09&maxdate=2008-09-21+16&cvsroot=%2Fcvsroot
Blocks: 420589
No longer blocks: 447604
Summary: New (68 bytes) mlk after bug 447604 checkin ... Need to adjust thresholds → New (68 bytes) mlk after ChatZilla bug 420589(!?) checkin ... Need to adjust thresholds
The leak is made of
[
1 instances of LiteralImpl with size 8 bytes
1 instances of RDF_Assertion with size 28 bytes
1 instances of nsRDFResource with size 24 bytes
1 instances of nsStringBuffer with size 8 bytes
]
NB: Easier to see it on the MacOSX logs.
That list of leaking objects looks like the kind of things the Chrome Registry might keep around for the additional line in ChatZilla's chrome.manifest (adding in bug 441221).

Do the leak tests invoke ChatZilla in any way? If they don't, I can't think of anything other than the chrome.manifest and additionally JARed files (bug 420589) that has changed that could remotely cause a leak.
(In reply to comment #5)
> looks like the kind of things the Chrome Registry might keep around

To be explicit, the point of this bug is
to fix the leak if possible,
otherwise to increase the SM leak thresholds.

> (adding in bug 441221).

KaiRo, would you like to try a backout on one of the boxes to confirm ?

(On my local Windows, I don't get these 8k test leaks: I didn't try to reproduce this additional one.)

> Do the leak tests invoke ChatZilla in any way?

(I don't think so, but not 100% sure.)
Blocks: 441221
Keywords: mlk
The leak tests don't invoke Chatzilla, and I don't think we'd leak chrome registry stuff, esp. as there's RDF in the new leaks and the new chrome registry is said to not use RDF (at least not that much).
But we know that we're leaking the extension manager RDF, and seeing http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/extensions/irc/xpi/resources&command=DIFF_FRAMESET&file=install.rdf&rev1=1.18&rev2=1.19&root=/cvsroot in the changeset makes me pretty sure that this is what we are adding to our known EM RDF leak, see bug 391318.

The solution for this would be to paper over it with rising leakThresholds and put even more emphasis on finding out how to fix bug 391318.
I adjusted the thresholds in http://hg.mozilla.org/build/buildbot-configs/rev/ff2f31d29222 so the boxes should go green now.

If you look at the changeset, you'll see that I didn't increase the threshold for everything but adjusted them to reality instead (recent cycles reflect the same numbers as reported in comment #0), apparently something decreased Mac and mochitest values before this increase happened across the board.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Summary: New (68 bytes) mlk after ChatZilla bug 420589(!?) checkin ... Need to adjust thresholds → Fix thresholds for EM-related mlk increase (68 bytes) after ChatZilla bug 420589 checkin
(In reply to comment #8)
> but adjusted them to reality instead

:-)

> apparently something decreased Mac and mochitest values before this increase happened across the board.

Hopefully, the (ongoing) work to fix the leaks reported by the various tests (suites) is starting to help here too ;->

Linux and Windows are Green again, MacOSX "would be" (without test failures):
V.Fixed
No longer blocks: 441221
Status: RESOLVED → VERIFIED
Depends on: 391318
Target Milestone: --- → seamonkey2.0alpha
Assignee: build-config → nobody
QA Contact: build-config → build-config
You need to log in before you can comment on or make changes to this bug.