Add outgoing e-mail addresses to address book creates duplicates

RESOLVED DUPLICATE of bug 129393

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 129393
10 years ago
9 years ago

People

(Reporter: Chris Rossi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080724)

When using the option to add outgoing e-mail addresses to address book, duplicate entries are created if email addresses differ by capitalization only.  For example, I already have an entry for: 'jane.doe@someplace.org' and Jane sends me an email where the from address is 'Jane.Doe@Someplace.org' and I hit 'Reply' and send my reply, the address 'Jane.Doe@Someplace.org' is added to my address book even though I already have an entry for Jane Doe which differs only by capitalization.

This becomes problematic when using the Zindus add-on to sync contacts with GMail since Google can't deal with duplicate contact entries.



Reproducible: Always

Steps to Reproduce:
1) Enable 'Automcatically add outgoing e-mail address to ... <address book>'
2) Add a contact to address book.
3) Send an email to that contact changing only the capitalization of the email address.

Actual Results:  
A second contact is added to address book.

Expected Results:  
Second contact is not added to address book because it is recognized as the same contact that is already in the address book.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129393
To the best of my knowledge this bug still exists in the main code.  To get it
fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.