If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Canceled changes to "Folder" field in bookmarks are applied

VERIFIED FIXED in fennec1.0a1

Status

Fennec Graveyard
Bookmarks
P2
normal
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: abillings, Assigned: mfinkle)

Tracking

Trunk
fennec1.0a1
x86
Linux
Bug Flags:
blocking-xul-fennec1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
If a user adds a bookmark and then edits the "Folder" field in the bookmark, the changes are committed even if the user selects "Cancel" in the bookmark editing dialog. This only happens for the "Folder" field and not "Tags" or "Title" there.

This was seen in Stuart's build 20080918185520.

Steps to Reproduce
1. Browse to a page (http://www.mozilla.org, for example).
2. Add a bookmark for it by clicking on the star in the right panel.
3. Click on the star in the right panel again to edit the bookmark.
4. Add "Blah" to the "Folder" field and select "Cancel".
5. Edit the bookmark again.

Result: When the bookmark is edited for the second time, "Blah" will be in the
Folder attribute even though the change was canceled. If this is tried with the "Tags" or "Title" fields, the data does not persist.

Comment 1

9 years ago
neil, can you take a look at this please?
Assignee: nobody → enndeakin
Flags: blocking-fennec1.0+
Priority: -- → P2
Target Milestone: --- → Fennec A1
I can take this one
Assignee: enndeakin → mark.finkle
Created attachment 340071 [details] [diff] [review]
clear out the folder textbox

the Folder field isn't used currently (separate bug), so we didn't have any code to init the text value when displaying the panel. So any text that was entered just stuck around. It really wasn't saved anywhere.

We clear it now.
Attachment #340071 - Flags: review?(gavin.sharp)
Attachment #340071 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mobile-browser/rev/67c14d267e35
(Assignee)

Updated

9 years ago
Duplicate of this bug: 456486
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Verified with a build from 2:20 today.
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.