Closed Bug 456529 Opened 12 years ago Closed 11 years ago

Create new cgi script to replace bulk.cgi & collect.cgi for new db schema

Categories

(Webtools Graveyard :: Graph Server, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rdoherty, Assigned: lars)

References

Details

Attachments

(1 file)

With the new db schema, we'll need to rewrite bulk.cgi and collect.cgi. While we're there, let's merge them.
Depends on: 456528
Duplicate of this bug: 452420
Blocks: 348785
Assignee: nobody → mark
Depends on: 457036
As discussed today:

These scripts have to update both the old database form and the new one for now, until we've figured out migration of everything to the new data.

In other words, Talos submits points of data, and we insert into both databases.
Assignee: mark → lars
Here's my first pass at covering both how Talos currently passes data and what needs to change to use the new schema:

https://wiki.mozilla.org/Perfomatic:SendingData
This tool sends mock data to a graph server - the data itself isn't very interesting but it is a quick way of checking to see if graph server collection scripts are operating correctly.

I'm not sure where this should be checked in, but it should be put into hg somewhere.  Also, post_file.py is checked in with the talos code (it is how talos sends data to the graph server) so it might be bad policy to check it in again?
Attachment #353303 - Flags: review?(rdoherty)
Attachment #353303 - Attachment is patch: false
Attachment #353303 - Attachment mime type: text/plain → application/zip
Comment on attachment 353303 [details]
test tool for old collect.cgi/bulk.cgi and new collect.cgi

I have no way to test this, but because it's a tool I'll r+ it and we can fix it if needed.

It should be checked in in /scripts, which is where utilities are put. I don't think it's a big deal to check in post_file.py twice.
Attachment #353303 - Flags: review?(rdoherty) → review+
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.