Account Settings:Identity:UI clean up

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
RESOLVED WORKSFORME
18 years ago
12 years ago

People

(Reporter: jglick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Minor UI fixes recommended based on UE Mail review.

1. Signature File: Clicking the "Choose" button and selecting a sig file should 
cause the signature file checkbox to be checked. (P3)
2. Identity: Reply to Address. Would be nice to have ghost text in the text 
field that says "Only needed if different from your email address".  If that is 
not possible, a tooltip with the text would be helpful. (P5)
3. Advanced dialog. Very cramped. Can it be a touch larger? (P4)
4. "Account Name:" Indent a few spaces. (P5)
5. Add a Group box around Identity items. (P3)
6. Indicate which account is the default. Parenthesis around the word 'default 
following the account, "(Default)" following account name. If that is not 
possible, bold the account name of the default account. (P2).
(Reporter)

Comment 1

18 years ago
nominate as b3mail
Keywords: b3mail

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 2

18 years ago
change b3mail to nsbeta3.
Keywords: b3mail → nsbeta3

Comment 3

18 years ago
I've got fixes for some of these in hand.
After they've been checked in, I'll move this past beta3
Status: NEW → ASSIGNED
Whiteboard: Partial fix in hand
Target Milestone: --- → M18

Comment 4

18 years ago
#5 is done (ooohh... ahhhh)

Comment 5

18 years ago
Adding mail4 triage nomination keyword.
Keywords: mail4

Comment 6

18 years ago
+ per mail triage for jennifer's P3 or higher items.
Whiteboard: Partial fix in hand → [nsbeta3+]Partial fix in hand

Comment 7

18 years ago
Adding myself to cc: list.

Comment 8

18 years ago
ok, this has been cleaned up a fair bit. Now that it's been cleaned up, I'm
going to remove all the nsbeta3 statuses and future it.
If anyone objects, say so now!
Keywords: mail4, nsbeta3
Whiteboard: [nsbeta3+]Partial fix in hand
Target Milestone: M18 → Future

Comment 9

18 years ago
massive reassign of account manager bugs -> sspitzer
please feel free to put me back on the CC if you have any questions/comments
Assignee: alecf → sspitzer
Status: ASSIGNED → NEW

Comment 10

18 years ago
Marking nsbeta1 to atleast get "Default" to appear next to the default name in
Account Settings. 
Keywords: nsbeta1
mass re-assign of account manager bugs to racham.
Assignee: sspitzer → racham

Comment 12

18 years ago
Per mail triage, I'm going to log a separate bug for #6 so it can be considered
for earlier fixing (new bug is 64230). This bug can be minused 

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 13

18 years ago
marking nsbeta1-

Comment 14

18 years ago
Mass assigning all racham's UI clean up bugs to me, with permission. Sorry for
the spam.
Assignee: racham → hwaara

Comment 15

18 years ago
Allright, some comments on the things jglick suggests we should change:

#2 I talked to mpt about this, and I don't think we should have some "ghosted
text" in the textfield. The user could get confused. And we can't add the text
besides, so I have no clue how we should fix this.

#3 Huh? In what way is this dialog small? How much larger do you think it should be?

#5 Already fixed.

#6 Racham, how do I, in code tell what account is default?

So left we have #1 and #4 . Which both are fairly easy to fix.

OS -> All
Platform -> All
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 16

18 years ago
#2 People will feel they are supposed to enter text into blank text fields. If 
they enter their existing email address into the "Reply to" field, every time 
they do a new Message, "Reply to" appears the Addressing area.  I was worried 
that might throw some folks off.  But I don't know the best answer. 4.x left the 
New Message Addressing area blank even if you entered a "Reply to" in the Prefs.

#3  Much better than it used to be.


Comment 17

18 years ago
*** Bug 57038 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
We have #1, #2, #4 and #6 left.

mpt and jglick: perhaps we could show some kind of "[i]" info button besides the
Reply-to textfield, to show that we need to tell the user something about this
field?

Otherwise I have no idea..
(Reporter)

Comment 19

18 years ago
I guess its a separate bug, but we should probably not show the "Reply to" in 
the Addressing area for each new message if the user didn't manually enter it 
for this particular message. 4.x behavior.

Comment 20

18 years ago
[changing URL to one that works]

> #2 People will feel they are supposed to enter text into blank text fields.

The appropriate fix for this is to use a checkbox which is off by default, and 
disable the text field if the checkbox is unchecked:

[ ] Use reply-to address (only needed if different from e-mail address)
    [                                                                 ]

4.x for Mac OS doesn't have extra text for reply-to at all (which is probably a 
bad idea). 4.x for Windows has the label for each field above (rather than to the 
left of) the field itself, which means that it has room to say `Reply-to address 
(only needed if different from e-mail address)'. In Seamonkey we don't really 
have room to do this, for a variety of reasons -- unnecessary text at the top of 
the pane, poor arrangement of buttons at the bottom of the pane, and a rich text 
composition checkbox which should really be in another pane (like it was in 4.x). 

Ultimately the Account Manager should probably be reworked to use a popup menu 
(listing accounts) followed by tabs (listing aspects of the selected account), 
rather than a tree widget -- the eye-watering repetition of `Server' and `Copies 
and Folders' is a classic symptom of a GUI using the wrong widget, and using both 
branches *and* leaves of the tree to show panels of options repeats one of the 
worst problems with the main preferences dialog. Using a popup menu and tabs 
instead would give us quite a bit more room for things like the checkbox I 
described above, too. But that belongs in a different bug.
(Reporter)

Comment 21

18 years ago
>The appropriate fix for this is to use a checkbox which is off by default, and 
>disable the text field if the checkbox is unchecked:
I like that.

>Ultimately the Account Manager should probably be reworked to use a popup menu.
Sounds like a good idea. I'd like to see that happen eventually.

Comment 22

17 years ago
FYI

Bug # 14059 has an entry which states:
"Account Settings and Address Book UE spec changed based on decisions made in
Mail Issues Meeting 10/14/99.

Account Settings Identity Dialog:  2 Radio Buttons

"Compose messages using:"
 - "Plain text"  - Default for News accounts
 - "Rich text (html)" - Default for Mail accounts

Address Book - Card Edit dialog:  Checkbox
"Prefers to receive rich text (html) mail"  - Default is unchecked."

I just want to verify whether this option will have one checkbox or 2 radio
buttons. This would also effect bug# 68194 which is is suggesting word changes.

Comment 23

17 years ago
*** Bug 14059 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 24

17 years ago
nbaca, in the bug you referenced, robin suggested a checkbox: "Compose messages 
in HTML format" for account settings.  Lets go with that.

Comment 25

17 years ago
I don't have enough time to promise I'll fix this, thus I'm reassigning to the
default owner of this component. Who knows, maybe I'll get around and fix it
after all - but I can't promise it. Sorry :(
Assignee: hwaara → racham
QA Contact: nbaca → esther
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 27

12 years ago
(In reply to comment #18)
> We have #1, #2, #4 and #6 left.

(In reply to comment #0)
> 1. Signature File: Clicking the "Choose" button and selecting a sig file
> should  cause the signature file checkbox to be checked. (P3)

The Choose button is disabled unless the checkbox is checked, which is a more typical dependency anyway.


> 2. Identity: Reply to Address. Would be nice to have ghost text in the text 
> field that says "Only needed if different from your email address".  If that
> is not possible, a tooltip with the text would be helpful. (P5)

This is argued at comment 15 & 16, and an alternate approach is suggested at 
comment 20.  It's been five years and I haven't seen this issue pop up anywhere, even in the newsgroups.


> 4. "Account Name:" Indent a few spaces. (P5)

WHO CARES?  It looks fine the way it is.


> 6. Indicate which account is the default.

This was handled separately by bolding the default account name.


=> WFM  --  if someone feels items #2 or #4 really need to be addressed, go ahead and reopen or create new bugs.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.