Message includes code in other mail readers

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
6 years ago

People

(Reporter: cputrdoc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2
Build Identifier: version 2.0.0.16 (20080708)

My manager (who uses Microsoft Outlook 2003) says whenever I send him a bulleted list, he sees code like this in my messages:
<!--[if !supportLists]-->-         <!--[endif]-->

He has requested I look into using a different email program.  I'd rather not.

Reproducible: Always

Steps to Reproduce:
1. Compose a message to an Microsoft Outlook 2003 user (Address Book can say this user prefers to receive "Unknown" format emails)
2. Create a formatted bulleted list
3. Send message
4. Have recipient open the message.
Actual Results:  
List will contain <!--[if !supportLists]-->-         <!--[endif]-->

Expected Results:  
If no bullet list is shown, then hyphens are used.

I realize it might be a Microsoft Outlook code problem, but if that's the defacto standard and it causes people like my manager to tell me to stop using Thunderbird, then it becomes a Thunderbird problem.
Did you send using plaintext or HTML or both?
And do you copy from Word, or some other Microsoft HTML editor, when you are composing the message? The string "supportLists" doesn't appear anywhere in Thunderbird's source code, but according to Google it's not uncommon to see that (in contexts other than Thunderbird sending email) when you copy Word's "HTML" and then view it in IE.
(Reporter)

Comment 3

10 years ago
Send using both HTML and plaintext.  The most recent instance was, in fact, copied from an unsaved Word 2003 document.
Could you attach the source of the message (sanitized, of course) as an attachment?
(Reporter)

Comment 5

10 years ago
Created attachment 340479 [details]
Sample email where this occurs

I guess there's nothing confidential about this so I'm posting it unedited.  This message, when sent to a coworker using Outlook 2003, shows all of the code I mentioned.  It will probably look just fine inside Thunderbird.

Comment 6

10 years ago
here too, composing an email in word 2003, then copy and paste the content into thunderbird (windows XP), make the <!--[if !supportLists]-->-         <!--[endif]--> code appear in formatted lists...

reading the message received by a thunderbird client hides the code, reading it from a microsoft mail client shows it

thunderbird v. 2.0.0.21
It seems that the problem here is Outlook not recognizing its (Word's) own conditional comments. Thunderbird is correct in not displaying the comment parts, but Outlook, for some reason, decides it wants to view the comments itself. I would also like to point out that IE 6 shows the same comments, unique among classes of web browsers (FF doesn't display it, nor does Elinks).

In short, unless you can demonstrate that TB is munging the HTML on paste, this is 100% a Microsoft non-standards-compliant idiocy problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 8

10 years ago
i'm happy with this... me too has arrived to understand that is dumb m$ product, anyway, probably a little patch not to paste unused and not valid html code (they are comments, so they are useless) could be welcome, not to annoy the final (l)user... ;P
i'd do it myself, but the code it's very messed up, and i couldn't find where to intervene in the code :((((
i'm looking in writing an extension
Just FYI for anyone who finds this bug, this extension purports to fix this issue:

https://addons.mozilla.org/en-US/firefox/addon/signature-fixer/

Comment 11

6 years ago
While I'm defiantly no a friend for Microsoft, I think it isn't a "100% a Microsoft non-standards-compliant idiocy problem" as was stated before by Joshua Cranmer, because  <!--..anything..--> is a long standing standard in HTML to insert comments. 

It really doesn't matter who - Microsoft, Apple or a regular Joe inserted INSIDE OFFICIAL HTML's Comment's TAG something, it simply should be ignored according to HTML law by Thunderbird. Otherwise we will still receiving complaints that Thunderbird breaking HTML messages that are very popular in corporate and small business environments.
You need to log in before you can comment on or make changes to this bug.