Closed Bug 45723 Opened 21 years ago Closed 21 years ago

consolodate nsWebShell and nsDocShell

Categories

(Core :: DOM: Navigation, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jud, Assigned: mikepinkerton)

References

Details

(Keywords: embed, memory-footprint, perf, Whiteboard: [nsbeta2+])

moving nsWebShell into the nsDocShell lib will reduce footprint as right now
we're loading both libs.

I'm going to move webshell into docshell and do some interface cleanup.
+
Keywords: embed, nsbeta2, perf
Whiteboard: nsbeta2+
Whiteboard: nsbeta2+ → [nsbeta2+]
over to pink as he's working on ditching the webshell lib on the mac and
converting it to docshell. pink, if you can't get to this, don't sweat it, just
close the bug as fixed anyway.
Assignee: valeski → pinkerton
Keywords: footprint
accepting last bit of mac cleanup work.
Status: NEW → ASSIGNED
Whiteboard: [nsbeta2+] → [nsbeta2+] eta 7/20
mac now no longer has a webshell library. all is handled in docshell.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+] eta 7/20 → [nsbeta2+]
*** Bug 46258 has been marked as a duplicate of this bug. ***
Marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.