Closed Bug 457890 Opened 12 years ago Closed 12 years ago

Lightning 0.9/Google Calendar 0.5 do not synchronize Google Alarms anymore

Categories

(Calendar :: Provider: GData, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: raulcristian, Assigned: Fallen)

References

Details

(Whiteboard: [gdata-0.5.1])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.13 (KHTML, like Gecko) Chrome/0.2.149.30 Safari/525.13
Build Identifier: 2.0.0.17 (20080914)

After installing Lightning 0.9 with Google Calendar Provider 0.5, the reminder alerts do not go off anymore for Google Calendar events after switching views (Calendar to Mail). They are removed from the calendar in Lightning, but they are still active in Google. Home reminders alerts still work as expected. All this worked perfectly well before upgrading to Lightning 0.9/Google Provider 0.5 (I have a laptop PC with Lightning 0.8 and Google Calendar Provider 0.4, and everything works as expected there). 

Reproducible: Always

Steps to Reproduce:
1. Go to Calendar, Update an event that is a Google Calendar event, set a Reminder, save it.
2. Everything seems to work, a small bell is shown in the calendar page.
3. Switch the view to Mail.
4. Switch the view to Calendar.
5. All the small bells have disappeared! Home calendar events still have the bell, though. It only affects events that are synchronized with a Google Calendar.
Actual Results:  
All the small bells have disappeared! Home calendar events still have the bell, though. It only affects events that are synchronized with a Google Calendar.

Expected Results:  
The reminders should still be there. Now they are all set to "No reminder" in Thunderbird. However, they have been accurately updated in Google Calendar (they still have the reminder set there, if you go and check them on the Google Calendar web site). 

This behavior happens after upgrading. I mean that the Google Calendar settings were previously introduced. In fact, everything else seems to work pretty well with the integration between Lightning and Google Calendar. It is just the reminders that are no longer working. It is annoying since you rely on reminders to be aware of events and tasks. Reminders are a MAJOR FEATURE of calendaring software!
Product: Thunderbird → Calendar
QA Contact: general → general
Component: General → Provider: GData
QA Contact: general → gdata-provider
Hi Raul,
i had the same problem and i got crazy about that.
I worked successfully one year with lightning and gcal and everything was good, before the update to 0.9. I can´t imagine what was programmed wrong and I hope
they resolve that important problem as soon as possible.
Let me now, guys, what can we do...
Hello,
I have the same problem since the update on Lightning 0.9. 
My configuration: Win.XP, Thunderbird 2.0.0.17, Lightning 0.9, Provider for google 0.5.

I hope a bugfix is coming soon?!
I have Windows XP too (SP2), but I don't know if it matters. Hey, please vote for this bug so it receives more attention from developers. I can't believe this thing is happening just to us.
No, I think also that is not a problem from XP or google. My opinion is, that is only a problem of version 0.9. Before the update all runs fine.

Vote is done.
Not sure -- in comment #0 Raul says his events still have alerts working in Google; for me, my events have lost their alerts in Google as well.  not sure if I'm following a slightly different procedure than he is.  In any case, these bugs sound very similar, that the alert-handling code has bitrotted somewhat.  I don't have the old versions of Lightning/GData, but I recall it worked correctly up through the beginning of September; maybe that can help triage when the bug crept in...
The problems looks very similar.
At my google-alerts is no problem. All input-data (reminder) in lightning is also in google.
Only the lightning-alerts are not working and unblanked.
Needs to be fixed for 0.5.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [gdata-0.5.1]
Duplicate of this bug: 456803
Attached patch Fix - v1Splinter Review
This patch should take care. It was definitely an issue regarding secondary calendars and primary calendars where you are not the organizer.

Everyone who is cc'd, please stay tuned. I'll post an xpi soon that urgently needs to be tested so I can release 0.5.1 hopefully this week.

It will be compatible with 0.9.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #342051 - Flags: review?(daniel.boelzle)
Attachment #342051 - Flags: review?(daniel.boelzle) → review+
Hello Philipp,

it sounds good! In this case, I think, we can wait. I wish you all goods to solve (fix) the problem.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f077212331c0>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Ah, my first merge/rebase. This is instead <http://hg.mozilla.org/comm-central/rev/12520dc55b89>
And now? Do you know if a update will release?
Duplicate of this bug: 459055
I have two installations where I'm checking this bug:  I'm using the latest Lightning Nightly Updater, and get

* TB2.0.0.17, Lightning 0.9 latest nightly and GData 0.5 latest nightly, and

* TB3.0b1pre latest nightly, Lightning 1.0pre nightly, and GData 0.6pre latest nightly.

On the TB3 setup, I get my alarms back, thanks!  But on the TB2 setup, I still don't -- browsing the code, I see that the changes in your attachment above haven't been merged into the code.  I've manually applied the patch to GData 0.5, and it gives me my alarms back there too, but I'm looking forward to 0.5.1...  :)
(In reply to comment #16)
> * TB2.0.0.17, Lightning 0.9 latest nightly and GData 0.5 latest nightly, and

There are no nightly builds for Lightning 0.9* or GData 0.5* anymore. You need to download the 0.5.1 release from <https://addons.mozilla.org/thunderbird/addon/4631>.
Thanks!  Out of curiosity, then, the Lightning Nightly Updater keeps pulling new versions, though, from http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/.  Is that just broken?
I didn't commit the changes for 0.5.1 to mozilla_1_8_branch or sunbird_0_9_branch. Not sure if I should though.

Ause? Daniel?

Unless I need to bring out another branch version, future patches will not be committed to 1.8 branch, so lightning nightly updater will only make sense on comm-central builds now.
Philipp, since 0.5.1 is aimed at 1.8 branch based Lightning/Sunbird builds, the corresponding changes should be committed to the 1.8 branch and the 0.9 branch, IMO.
Thank's a lot! It works with the new update of google-Provider. Problem is solved. Good job!
Verified per comment 21
Status: RESOLVED → VERIFIED
Thank you so much Philipp! I was out of the world because I have been father (again) last week, now I got back and found this nice present. Keep the good work!
Checked in on HEAD, MOZILLA_1_8_BRANCH and SUNBIRD_0_9_BRANCH since this patch is relevant for the branch release that fits with 0.9.

This patch is contained in the Provider for Google Calendar 0.5.1
Not sure this is fully fixed - I just created an event with an alarm, which did sink the alarm with gCal. But I changed the length of the appointment (1 hour to 1 hours) and the alarm was lost again. Also happens when you change the time (start or finish) of an event. In this case it removes the alarm from gCal as well. Should I open a new bug for this?
I also have this issue - events can be created with categories and alarms, but categories/alarms cannot be added to events, and any edit to the event removes all alarms and categories.

Sunbird 0.9, Provider for Google Calendar 0.5.1

Since this old and marked fixed, I'll file a new bug if I can't find something open.
Hi,

It´s not fixed or it´s a new bug!
I´m from germany, sorry, my english is not very good.
	
I also have this problem. No reminders in Google Calendar and Thunderbird / Lightning. I hav Windows XP Prof SP 3, Thunderbird 2.0.0.21, Lightning 0.9 and Calendar Provider 0.51. 
Luckily I had my old Lightning calendar. Google Calendar off, turned on the old calendar, reminders work.

Uwe
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.