Combobox unusable when in rowspan

VERIFIED DUPLICATE of bug 45350

Status

()

P1
normal
VERIFIED DUPLICATE of bug 45350
19 years ago
18 years ago

People

(Reporter: cheng, Assigned: karnaze)

Tracking

({helpwanted})

Trunk
x86
All
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][dogfood+], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Go to the Query page, and select a remembered query from the drop down box other
than the first one.  After that, the down arrow disappears and you cannot change
the selected value again.

Tested on 2000071810 on Linux, and Asa says he can see this on 2000071808 on
Win32 as well.

Comment 1

19 years ago
After using the combobox one time when in a rowspan (in a table) it becomes 
completely wacked and unusable.
Status: NEW → ASSIGNED
Summary: Options in drop box for Remembered Query cannot be reselected → Combobox usable when in rowspan
Target Milestone: --- → M17

Comment 2

19 years ago
Created attachment 11571 [details]
very small testcase

Comment 3

19 years ago
The cell is shrinking from 1005 twips to 360 twips. If you resize the window 
then the cell pops back to 1005 twips.

My guess is that when the reflows happen from selecting a new value the table 
cell's row doesn't realize it is part of a span and sets the cell height to just 
the row height instead of the entire span height.

reassigning
Assignee: rods → karnaze
Status: ASSIGNED → NEW
Summary: Combobox usable when in rowspan → Combobox unusable when in rowspan

Comment 4

19 years ago
I'm running 2000080714 on Win98

I see a problem with the dropdown box when my mouse enters it, not just when I
use it; the box goes completely blank.  I can still get to the box in two ways,
though:

1) I can click on the upper border of the box and get the list to drop down.
   However, this doesn't allow me to make a selection.
2) I resize the window.  Then, I can move the pointer into the box and make a
   selection successfully.  The box becomes unusable again if I choose a
   selection other than the one already in the box.

Comment 5

18 years ago
*** Bug 48769 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
nominating because it makes the remembered queries on Bugzilla not work.
Keywords: nsbeta3

Comment 7

18 years ago
karnaze is already over-allocated for beta3 bugs. I'm gonna have to deny this 
one unless we can get another resource to look at tables. Adding helpwanted to 
kwds.
Keywords: helpwanted
Whiteboard: [nsbeta3-]
Target Milestone: M17 → M18

Comment 8

18 years ago
*** Bug 48656 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 47446 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
please test the test case is 47446 when this is fixed to verify that it really 
is a dup.

this has the potential to make many pages unusable.  I suggest nsbeta3+.  
Re-nominating.  I could help Chris with this one.
Whiteboard: [nsbeta3-]

Comment 11

18 years ago
Approving for beta3 (based mostly on buster's opinion and offer to help).
Whiteboard: [nsbeta3+]

Comment 12

18 years ago
Related to 45350?

Updated

18 years ago
Priority: P3 → P1

Comment 13

18 years ago
adding "dogfood" keyword to push up the priority.  duplicate bugscape bug 2007 
has already been marked dogfood+
Keywords: dogfood
This might be related to bug 49888 "buttons incorrectly disappear on mouseclick 
event" (it used to be mouseover event). There are several conditions that must 
be fulfilled for that bug to appear, but one of them is that the button must be 
in a table that has rowspan(s) >= 2.

Comment 15

18 years ago
PDT agrees P1 - and leger agrees...oh yeah..dogfood+ baby!
Whiteboard: [nsbeta3+] → [nsbeta3+][dogfood+]
(Reporter)

Comment 16

18 years ago
This seems to be fixed in Linux 2000090508.  Can anyone confirm?

Comment 17

18 years ago
I'm running win98 build 0222090508 and the problem seems to be gone for me, too.
(Assignee)

Comment 18

18 years ago
It sounds like a dup of 45350 which I just fixed.

*** This bug has been marked as a duplicate of 45350 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 19

18 years ago
I don't think this is the same thing, but it's fixed anyway.
Marking VERIFIED FIXED on:
- LinuxRH62 2000-09-13-08-M18 Commercial
- Win98     2000-09-13-08-M18 Mozilla
- MacOS86   2000-09-13-04-M18 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.