SELECT strangeness in spanned TABLE cells

VERIFIED DUPLICATE of bug 45818

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 45818
18 years ago
18 years ago

People

(Reporter: unapersson, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
When you use a select in a table cell that spans other table cells you get some
very strange results. I have observed the following:

1) empty SELECT box is drawn with no dropdown arrow + content
2) SELECT box disappears when you select another item from the combo
3) Arrow disappears when item is selected and will no longer allow you to drop
down the list.

1)&2) can be demonstrated by the attached test case. The SELECT in a normal TD
works, but those in spanned TDs act strangely. Behaviour is sometimes different
on refresh / revisit to page.

3) I couldn't recreate this in my testcase, but it happens all the time when I
try and select a new saved query in bugzilla. I will try and create a testcase
from the bugzilla page to recreate this.

Build ID: 2000080220

This could be a table bug or a form bug but I've put it against tables for now.
(Reporter)

Comment 1

18 years ago
Created attachment 12312 [details]
Example showing strange behaviour
(Reporter)

Comment 2

18 years ago
Created attachment 12313 [details]
Fragment from Bugzilla showing 3)
(Reporter)

Comment 3

18 years ago
This bug has just worsened in a recent nightly (2000080714). If I mouse over 
the third select box in the first attachment it disappears. If I mouse over the 
select box in the second attachment the dropdown arrow disappears and I can't 
choose a different selection.

Comment 4

18 years ago
Couldn't reproduce the mouseover issue in M17/Win2k, but I
*could* reproduce the described select box redraw problem by
selecting the second or third dropdown options in:

- the third example in the first attachment (not first or second)
- the example in the second attachment


Comment 5

18 years ago
this is a duplicate of bug 45818

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 45818 ***

Comment 7

18 years ago
Verified dup of #45818
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.