DOCTYPE is ignored if not at the very beginning of the document

VERIFIED FIXED in M18

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Pierre Saslawsky, Assigned: rickg)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3+ fix waiting.)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
- Extracted from bug 45804.
- Tested on the Mac but it must be a cross-platform problem.

A regression was introduced between M17 06/28 and M17 06/30: if spaces are 
inserted before the DOCTYPE declaration, the declaration is ignored.

See the testcase that I'm going to attach.
(Reporter)

Comment 1

17 years ago
Created attachment 11556 [details]
testcase
(Reporter)

Updated

17 years ago
Keywords: regression
I suspect this would be fixed by the DOCTYPE parsing code I attached to bug
44340.
Blocks: 34662

Updated

17 years ago
OS: Mac System 9.0 → All
Hardware: Macintosh → PC

Updated

17 years ago
Hardware: PC → All

Comment 3

17 years ago
A common problem that should probably be fixed for beta3.
Status: NEW → ASSIGNED
Keywords: nsbeta3

Comment 4

17 years ago
Marking nsbeta3-
Whiteboard: [nsbeta3-]
(Assignee)

Comment 5

17 years ago
Trivial fix waiting in my tree.
Assignee: harishd → rickg
Status: ASSIGNED → NEW
Whiteboard: [nsbeta3-] → [nsbeta3-] fix waiting.
(Assignee)

Comment 6

17 years ago
Moving back to nsbeta3+. Easy fix in my tree.
Whiteboard: [nsbeta3-] fix waiting. → nsbeta3+ fix waiting.
(Assignee)

Comment 7

17 years ago
Setting correct milestone.
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 8

17 years ago
My error was that I didnt set the parse process up correctly to ignore ws. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Keywords: vtrunk
Er, not vtrunk, just plain VERIFIED, since it was fixed before branching!
Status: RESOLVED → VERIFIED
Keywords: vtrunk
You need to log in before you can comment on or make changes to this bug.