Closed Bug 458486 Opened 16 years ago Closed 15 years ago

test_idcheck.xul : preferences.xul leaks

Categories

(SeaMonkey :: Preferences, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a3

People

(Reporter: sgautherie, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: memory-leak)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b1pre) Gecko/20081004 SeaMonkey/2.0a2pre] (home, optim default) (W2Ksp4)

(After working around bug 391318.)
And after working around bug 458484 (by disabling it),

"chrome://communicator/content/pref/preferences.xul"
leaks
{
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 20 bytes during test execution (should have leaked no more than 0 bytes)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of DirPrefObserver with size 16 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsVoidArray with size 4 bytes
}

NB:
I wonder why this leak is not reported when bug 458484 is "active".
I tried to swap their order (and remove the other tests) in the list: same results.
Depends on: 458988
Blocks: 452205
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081116 SeaMonkey/2.0a2pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/8b3caddca8f5
+http://hg.mozilla.org/comm-central/rev/ebcb28433bfe)

Still there.
Flags: wanted-seamonkey2?
It looks like bug 391318 comment 51 checkin "hided" this leak.

NB: Resolution here depends on bug 391318 (and bug 458484) future(/followup)...
Depends on: 391318
Flags: wanted-seamonkey2?
Target Milestone: --- → seamonkey2.0a3
(In reply to comment #2)
> It looks like bug 391318 comment 51 checkin "hided" this leak.

Confirmed, after commenting out that new code.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20081221
SeaMonkey/2.0a3pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/b839ff0630c6
 +http://hg.mozilla.org/comm-central/rev/2a4c4c1f0feb + bug 469606 patch)
(In reply to comment #2)
> NB: Resolution here depends on bug 391318 (and bug 458484) future(/followup)...

Then: V.Fixed + V.WorksForMe = R.WorksForMe :->
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
No longer blocks: 452205
(In reply to comment #4)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20081222 SeaMonkey/2.0a3pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/31dbaf4ca0c4
 +http://hg.mozilla.org/comm-central/rev/113540504a46 + bug 469606 patch)

Update:
while bug 391318 did hide this leak (too) yesterday,
bug 460941 fixed its cause today :-)

R.Fixed, per comment 0 "steps".
Depends on: 460941
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.