Intermittent (Chrome) "TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!" after "/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay" on SeaMonkey tinderboxes

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
seamonkey2.0a3
crash, intermittent-failure
Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I've been noticing this for a (short) while.

I don't know (= didn't check (yet)) if this test (bug 448343) is "at fault",
or if it could be a "TraceMonkey" landing regression, or the like ?

*****

The location is always the same;
but the reported error varies "a little".

Examples:

*** Linux

[
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1219634265.1219638505.984.gz&fulltext=1#err0
Linux comm-central dep unit test on 2008/08/24 20:17:45

*** 1564 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay
pure virtual method called
terminate called without an active exception
/builds/slave/comm-central-linux/build/objdir/mozilla/dist/bin/run-mozilla.sh: line 131: 14917 Aborted                 "$prog" ${1+"$@"}
ERROR FAIL Exited with code 34304 during test run
TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!
]

*** MacOSX

[
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1219683342.1219688027.11731.gz&fulltext=1#err33
MacOSX 10.4 comm-central dep unit test on 2008/08/25 09:55:42

*** 1594 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay
ERROR FAIL Exited with code 11 during test run
TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!
]

[
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1219692727.1219697521.3693.gz&fulltext=1#err33
MacOSX 10.4 comm-central dep unit test on 2008/08/25 12:32:07

*** 1603 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay
ERROR FAIL Exited with code 4 during test run
TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!
]

*** Windows

[
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1219691707.1219697079.2469.gz&fulltext=1#err27
Win2k3 comm-central dep unit test on 2008/08/25 12:15:07

*** 1574 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay

command timed out: 1200 seconds without output
SIGKILL failed to kill process
using fake rc=-1
program finished with exit code -1

remoteFailed: [Failure instance: Traceback from remote host -- Traceback (most recent call last):
NEXT ERROR Failure: buildbot.slave.commands.TimeoutError: SIGKILL failed to kill process
]
]
(Reporter)

Comment 1

10 years ago
(In reply to comment #0)
> I don't know (= didn't check (yet)) if this test (bug 448343) is "at fault",

Bug 446281 !
Depends on: 446281
No longer depends on: 448343
(Reporter)

Comment 2

10 years ago
Fwiw, here are the tests which should happen instead of the error:
[
*** 1594 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay

*** 1595 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: preferences.xul#prefDialog
*** 1596 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: preferences.xul#bundle_prefutilities
*** 1597 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: preferences.xul#prefsTree
]
(Reporter)

Comment 3

10 years ago
Another variation:
[
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1219734293.1219738488.3253.gz#err2
Linux comm-central dep unit test on 2008/08/26 00:04:53

*** 1573 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay
/builds/slave/comm-central-linux/build/objdir/mozilla/dist/bin/run-mozilla.sh: line 131: 20076 Segmentation fault      "$prog" ${1+"$@"}
ERROR FAIL Exited with code 35584 during test run
TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!
]
(Reporter)

Comment 4

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1220872322.1220877083.19138.gz#err33
MacOSX 10.4 comm-central dep unit test on 2008/09/08 04:12:02
(Reporter)

Comment 5

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1221046913.1221051855.15976.gz
Win2k3 comm-central dep unit test on 2008/09/10 04:41:53
(Reporter)

Comment 6

10 years ago
Karsten, any hint on how to better diagnose, maybe fix, this ?
(Reporter)

Comment 7

10 years ago
I may (or not) have found a clue while looking for something else:

All 3 boxes currently log: (when this bug doesn't occur)
[
*** 891 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: navigator.xul#nav-buttons-box

Double id='contentAreaContextSet' detected in chrome://navigator/content/navigator.xul:
  Tree 0:
    popupset contentAreaContextSet [27]
    window main-window [21]
    #document undefined [0]
  Tree 1:
    popupset contentAreaContextSet [2]
    vbox sidebar-box [0]
    hbox  [31]
    window main-window [21]
    #document undefined [0]

*** 892 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: navigator.xul#sidebar-splitter
]

Issues:
1) There is no "FAIL" message, so this is not reported :-(
2) The duplication probably needs to be fix too :->
Flags: blocking-seamonkey2.0a1?

Comment 8

10 years ago
The |id='contentAreaContextSet'| thing intentionally doesn't throw an error, as there's no way around it, this is a sidebar thing and I think extensively discussed in the original bug that introduced that test.

Not blocking a release by test box strangeness.
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1-
(Reporter)

Comment 9

10 years ago
This still happens rather (very) often :-(

As with
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1224098097.1224101848.24786.gz
Linux comm-central dep unit test on 2008/10/15 12:14:57
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1224093694.1224098979.16081.gz
MacOSX 10.4 comm-central dep unit test on 2008/10/15 11:01:34

(Maybe fixing the (2) leaks will help !?)
Depends on: 458484, 458486
Flags: wanted-seamonkey2?
(Reporter)

Comment 10

10 years ago
(In reply to comment #9)
> (Maybe fixing the (2) leaks will help !?)

No, fixing bug 458484 and bug 458486 did not help.

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1229902300.1229905730.13571.gz
Linux comm-central dep unit test on 2008/12/21 15:31:40

Bug still there.
No longer depends on: 458484, 458486
Keywords: crash
(Reporter)

Comment 11

10 years ago
A different error for MacOSX:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1229855141.1229860329.29456.gz&fulltext=1
MacOSX 10.4 comm-central dep unit test on 2008/12/21 02:25:41

*** 2011 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay
pure virtual method called
terminate called without an active exception
ERROR FAIL Exited with code 6 during test run
}
(Reporter)

Comment 12

10 years ago
(In reply to comment #10)
> No, fixing bug 458484 and bug 458486 did not help.

(Let's see if bug 460941, which actually fixed bug 458486, will help here...)
(Reporter)

Updated

10 years ago
Depends on: 458484
(Reporter)

Comment 13

10 years ago
(In reply to comment #12)
> (Let's see if bug 460941, which actually fixed bug 458486, will help here...)

It did not:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1230043616.1230048761.8612.gz
MacOSX 10.4 comm-central dep unit test on 2008/12/23 06:46:56
(Reporter)

Comment 14

10 years ago
Last occurrences of this bug were
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1232358068.1232362133.21046.gz
Linux comm-central dep unit test on 2009/01/19 01:41:08

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1232398022.1232406345.22529.gz
MacOSX 10.4 comm-central dep unit test on 2009/01/19 12:47:02

(No Windows occurrence since at least 2009-01-01.)
}

Fix timeframes could be:
http://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2009-01-19+12%3A00&enddate=2009-01-21
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-01-19+12%3A00&enddate=2009-01-21
or later...

R.WorksForMe
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 458484
Flags: wanted-seamonkey2?
Resolution: --- → WORKSFORME
Summary: Intermittent "TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!" after "/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay" on SeaMonkey tinderboxes → Intermittent (Chrome) "TEST-UNEXPECTED-FAIL | runtests-leaks | missing output line for total leaks!" after "/test_idcheck.xul | check id: editor.xul#bundle_utilityOverlay" on SeaMonkey tinderboxes
Target Milestone: --- → seamonkey2.0a3
Whiteboard: [orange]

Comment 15

10 years ago
Seems to be back for Windows on 16th March:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1237247953.1237253272.17948.gz

Last working one started building 2009/03/16 13:07:28, first failing one started building 2009/03/16 16:59:13

Bustage timeframes:
http://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2009-03-16+13%3A07%3A28&enddate=2009-03-16+16%3A59%3A13
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-03-16+13%3A07%3A28&enddate=2009-03-16+16%3A59%3A13
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 16

10 years ago
(In reply to comment #15)
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1237247953.1237253272.17948.gz
> started building 2009/03/16 16:59:13

This build doesn't have this bug:
{
*** 5214 INFO TEST-PASS | chrome://mochikit/content/chrome/suite/common/tests/chrome/test_idcheck.xul | check id: preferences.xul#mousewheelWithShiftKeySysNumchars
*** 5216 INFO Running chrome://mochikit/content/chrome/test_sample.xul...
[...]
}
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.