browser "forgets" last page visited after window.location.href is modified

VERIFIED DUPLICATE of bug 58906

Status

()

Core
Document Navigation
P3
normal
VERIFIED DUPLICATE of bug 58906
18 years ago
10 years ago

People

(Reporter: Dave, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla0.9.1
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview Description: 

After viewing info on a model at carpoint, the back button will take you to the
page you were at before going to that site instead of the main carpoint page.

Steps to Reproduce: 
1) start mozilla and visit a page... we'll call it www.foobar.com
2) go to http://carpoint.msn.com and choose a make and model to view
3) click the "go" button
4) hit the back button which should take you back to carpoint.msn.com but
instead takes you to www.foobar.com

Actual Results: 

browser goes back two pages instead of one, "forgetting" the page where the
onClickGo() ocurred.

Expected Results: 

browser goes back to page containing the onClickGo()

Reproducibility: 

Always.

Build Date & Platform Bug Found: 

2000071810/Linux

Additional Builds and Platforms Tested On: 

works on NS4.7/IE5.1

Comment 1

18 years ago
Browser, not engine - reassigning to DOM Level 0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 2

18 years ago
A similar thing happen on http://www.cnn.com/, at the upper right corner with
the list of shows.  The drop list changes location.href when the onChange event
is triggered.

Comment 3

18 years ago
I think this is more of a history bug than a DOM bug.  Confirming on 2000071910
on Linux.
Status: UNCONFIRMED → NEW
Component: DOM Level 0 → History
Ever confirmed: true
radha, could you have a look at this?
Assignee: jst → radha
This is JS history fiasco.
Status: NEW → ASSIGNED
Depends on: 18321
Target Milestone: --- → M18

Comment 6

18 years ago
*** Bug 46355 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
is this related to bug 39938 by any chance?
Blocks: 47238

Comment 8

18 years ago
updating qa contact
QA Contact: desale → claudius

Comment 9

18 years ago
updating qa contact
This got fixed when 18321 was fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Are you sure this is fixed?  I cannot access carpoint for some reason, but on
http://www.cnn.com, if you select something from the dropbox on the upper left
(CNN sites) and select one of them, then pressing "Back" skips over the cnn main
page.  This has been tested on 2000080308 (M18) on Linux.
(Reporter)

Comment 12

18 years ago
I'm still seeing the described behaviour on carpoint with 2000080308/Linux

Comment 13

18 years ago
Reopening based on comments from various people.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 14

18 years ago
this now works with 2000081020/Linux. Setting back to fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

18 years ago
CNN test case also works (2000081020/Linux)
(Reporter)

Comment 16

17 years ago
I'm seeing this again on 2001022809/Linux. It's no longer related to onClickGo,
however, so reopening and changing summary to reflect new problem: modifying
window.location.href causes page to be removed from session history.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: browser "forgets" last page visited after onClickGo() → browser "forgets" last page visited after window.location.href is modified
Status: REOPENED → ASSIGNED
Target Milestone: M18 → mozilla0.9.1
The problem here is not location.href. The problem is the same as in bug 56806.
THe images in the subframe take a long time to load. If you jump to another site
while the image in the subframe is laoding, it confuses SH. This is reported in
56806. 

*** This bug has been marked as a duplicate of 56806 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE
sorry, that should have been 58906.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 58906 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
verified dups
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.