Closed Bug 458655 Opened 13 years ago Closed 13 years ago

Position Mac About dialog somewhere better than 0:0

Categories

(Thunderbird :: General, defect, P3)

All
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: philor, Assigned: philor)

References

()

Details

Attachments

(1 file)

Since on OS X we do window.open rather than window.openDialog for the About window, we don't get to just use centerscreen for positioning, and since we don't do anything else, we currently open it jammed into the upper left corner. While we're stealing the Fx moveTo, we should take the opportunity to move the script out of the XUL (where I lose a minute or two every time, saying "wait, where's our aboutDialog.js?").
Attached patch Fix v.1Splinter Review
A little copy, a little paste, a little whitespace cleanup...
Attachment #341892 - Flags: review?(bugzilla)
Attachment #341892 - Attachment is obsolete: true
Attachment #341892 - Flags: review?(bugzilla)
Comment on attachment 341892 [details] [diff] [review]
Fix v.1

Oy.
Not strictly a duplicate, but close enough.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458454
On second thought, if Magnus is stalled there, what better way to rub salt in his wounds than to bitrot him?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment on attachment 341892 [details] [diff] [review]
Fix v.1

*Now* I'm the only one in your queue with this same copy-paste!
Attachment #341892 - Attachment is obsolete: false
Attachment #341892 - Flags: review?(bugzilla)
Status: REOPENED → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Thunderbird 3
Comment on attachment 341892 [details] [diff] [review]
Fix v.1

+  var iframe = document.getElementById("creditsIframe");
+  iframe.setAttribute("src", "");

I know this is just copy and paste, but I think whilst we're here, lets dump the intermediate variable.

+  var modes = document.getElementById("modes");
+  modes.setAttribute("selectedIndex", gSelectedPage);

ditto here.
Attachment #341892 - Flags: review?(bugzilla) → review+
http://hg.mozilla.org/comm-central/rev/723d31daabb3
Hardware: PC → All
Target Milestone: Thunderbird 3 → Thunderbird 3.0b1
Status: ASSIGNED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.