[imap?] repeated thread expand, collapse make messages disappear from thread pane [eat msg] then crash [@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]

RESOLVED WORKSFORME

Status

MailNews Core
Database
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: ovidiu, Unassigned)

Tracking

({crash})

Trunk
x86
Windows Vista
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
[@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]

bp-41102878-93f5-11dd-9e3b-001cc4e2bf68

0      msvcr80.dll      msvcr80.dll@0x1537a      
1     xpcom_core.dll     nsTArray_base::ShiftData     nsTArray.cpp:173
2     thunderbird.exe     nsMsgDBView::CollapseByIndex     nsMsgDBView.cpp:4457
3     thunderbird.exe     nsMsgDBView::ToggleExpansion     nsMsgDBView.cpp:4273
4     thunderbird.exe     nsMsgDBView::ToggleOpenState     nsMsgDBView.cpp:1869
5     xpcom_core.dll     NS_InvokeByIndex_P    
xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
6     thunderbird.exe     XPCWrappedNative::CallMethod    
js/src/xpconnect/src/xpcwrappednative.cpp:2405
7     thunderbird.exe     XPC_WN_CallMethod    
js/src/xpconnect/src/xpcwrappednativejsops.cpp:1477



FWIW, this happens in Imap and not in [the same] pop. May be important or not.

Steps: 
In the thread pane I have a certain thread where twisty does not expand and on collapse it actually collapses the msg under it. If repeat the +/- it eats progressively the msg under it and eventually crashes when there is nothing left and would eat itself.

Repro :
always on a certain thread, not others. 
I can provide mbox and msf as this is test profile. And even accessing that Imap. But I would like to send it on request rather than just public attach as it has the test addresses and it's about an imap one.

id's: Insiting I eventually get a crash with 
Crash ID: bp-41102878-93f5-11dd-9e3b-001cc4e2bf68
Crash ID: bp-bdae1687-93f5-11dd-a99f-001a4bd43ed6
and more ..


This is derived from bug 456332 where I found it playing, but has nothing to do with that [UI] issue.

Please change components etc as necessary.

Comment 1

9 years ago
regression?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [imap?] thread expand collapse make messages disappear from thread pane [eat msg] → [imap?] repeated thread expand, collapse make messages disappear from thread pane [eat msg] then [@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]
Depends on: 283238

Comment 2

8 years ago
ovidiu, still see this and bug 456332?  (views have changed a lot in last couple months)

Comment 3

8 years ago
bug 524266 is likely the same, and has a test case, and a patch.
(Reporter)

Comment 4

8 years ago
This is about a very specific thread in a very specific profile that did this all the time. Not elsewhere.

If it is interesting to see what degenerated in that, I think I have that mbox+msf and can provide as they are test profile. 
But 
-I have narrowed it down to that specific point, 
-it belongs to a profile used under lots of nightlies , 
-I did not use it since betas, I think, and had no similar persistent issues
so it's WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Summary: [imap?] repeated thread expand, collapse make messages disappear from thread pane [eat msg] then [@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion] → [imap?] repeated thread expand, collapse make messages disappear from thread pane [eat msg] then crash [@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]
You need to log in before you can comment on or make changes to this bug.