in shell/shell_toplevel.as File exists has wrong type

VERIFIED FIXED in Future

Status

Tamarin
Virtual Machine
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Dan Schaffer, Assigned: Dan Schaffer)

Tracking

unspecified
Future
x86
Mac OS X
Bug Flags:
in-testsuite +
wanted-flashplayer10 +
flashplayer-qrb +
flashplayer-triage +

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
The File.exists implementation in FileClass.cpp returns a bool so in shell_toplevel.as the exists function should have a return type of Boolean not String.

After changing exists to return Boolean and rebuilding the shell exists works correctly.
Flags: wanted-flashplayer10+
Flags: in-testsuite+
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Comment 1

9 years ago
please add patch and get it reviewed
Assignee: nobody → dschaffe
Status: NEW → ASSIGNED
Flags: flashplayer-qrb? → flashplayer-qrb+
Target Milestone: --- → Future
(Assignee)

Comment 2

9 years ago
Created attachment 342902 [details] [diff] [review]
patch for 459284

patch changes shell_toplevel.as File.exists return type to Boolean.  rebuild shell_toplevel files.  add a testcase for File.
Attachment #342902 - Flags: review?(tierney)

Updated

9 years ago
Attachment #342902 - Flags: review?(tierney) → review+
(Assignee)

Comment 3

9 years ago
submitted patch: 
details:   http://hg.mozilla.org/tamarin-central/?rev/07fa3fa55d42
changeset: 691:07fa3fa55d42

added a testcase in acceptance tests.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Status: RESOLVED → VERIFIED

Updated

9 years ago
Duplicate of this bug: 382170
You need to log in before you can comment on or make changes to this bug.